在线支持 提供及时的技术支持与服务

常见问题

生成树算法使用路径成本来确定设备之间的最佳路径。 因此,应将较低的值分配给连接到较快介质的端口,将较高的值分配给具有较慢介质的端口。

默认情况下,系统会自动检测每个端口上使用的速度和双工模式,并根据下面显示的值配置路径成本。
mceclip0.png
 

* STP的路径成本不是由路径成本方法短或长配置的。

用户可以通过以下命令配置指定接口的生成树路径成本。

[CLI Command]
spanning-tree cost {cost}
cost - 端口的路径成本。
(范围:0表示自动配置,1-65535表示短路径成本法,1-200,000,000表示长路径成本法)

计算端口通道上的生成树路径成本。

1.端口通道的活动Eth1 / 1。

Console#show interfaces brief
Interface Name Status PVID Pri Speed/Duplex Type Trunk
--------- ----------------- --------- ---- --- ------------- ------------ -----
Eth 1/ 1 Up 1 0 Auto-1000full 1000BASE-T 1

中继 1上的生成树路径成本为5000。

Console#show spanning-tree brief
Interface Pri Designated Designated Oper STP Role State Oper
Bridge ID Port ID Cost Status Edge
--------- --- --------------------- ---------- -------- ------ ---- ----- ----
Trunk 1 128 32768.8CEA1B8AC667 128.57 5000 EN ROOT FWD No

中继 1的生成树路径成本为10000(1G)/ 2 = 5000(中继)。
中继 1上的生成树路径成本为5000(中继)/ 1 = 5000。


2.端口通道的活动Eth1 / 1和Eth1 / 2。

Console#show interfaces brief
Interface Name Status PVID Pri Speed/Duplex Type Trunk
--------- ----------------- --------- ---- --- ------------- ------------ -----
Eth 1/ 1 Up 1 0 Auto-1000full 1000BASE-T 1
Eth 1/ 2 Up 1 0 Auto-1000full 1000BASE-T 1

中继 1上的生成树路径成本为2500。

Console#show spanning-tree brief
Interface Pri Designated Designated Oper STP Role State Oper
Bridge ID Port ID Cost Status Edge
--------- --- --------------------- ---------- -------- ------ ---- ----- ----
Trunk 1 128 32768.8CEA1B8AC667 128.57 2500 EN ROOT FWD No

中继 1上的生成树路径成本为5000(中继)/ 2 = 2500。


3.端口通道的活动Eth1 / 1&Eth1 / 2和Eth1 / 3。

Console#show interfaces brief
Interface Name Status PVID Pri Speed/Duplex Type Trunk
--------- ----------------- --------- ---- --- ------------- ------------ -----
Eth 1/ 1 Up 1 0 Auto-1000full 1000BASE-T 1
Eth 1/ 2 Up 1 0 Auto-1000full 1000BASE-T 1
Eth 1/ 3 Up 1 0 Auto-1000full 1000BASE-T 1

中继 1上的生成树路径成本为1666。

Console#show spanning-tree brief
Interface Pri Designated Designated Oper STP Role State Oper
Bridge ID Port ID Cost Status Edge
--------- --- --------------------- ---------- -------- ------ ---- ----- ----
Trunk 1 128 32768.8CEA1B8AC667 128.57 1666 EN ROOT FWD No

中继 1上的生成树路径成本为5000(中继)/ 3 = 1666。

 

4.端口通道有效Eth1 / 1&Eth1 / 2&Eth1 / 3&Eth1 / 4。

Console#show interfaces brief
Interface Name Status PVID Pri Speed/Duplex Type Trunk
--------- ----------------- --------- ---- --- ------------- ------------ -----
Eth 1/ 1 Up 1 0 Auto-1000full 1000BASE-T 1
Eth 1/ 2 Up 1 0 Auto-1000full 1000BASE-T 1
Eth 1/ 3 Up 1 0 Auto-1000full 1000BASE-T 1
Eth 1/ 4 Up 1 0 Auto-1000full 1000BASE-T 1

中继 1上的生成树路径成本为1250。

Console#show spanning-tree brief
Interface Pri Designated Designated Oper STP Role State Oper
Bridge ID Port ID Cost Status Edge
--------- --- --------------------- ---------- -------- ------ ---- ----- ----
Trunk 1 128 32768.8CEA1B8AC667 128.57 1250 EN ROOT FWD No

中继 1上的生成树路径成本为5000(中继)/ 4 = 1250。

支持型号和软件版本:
ECS4120系列v1.2.2.24及以上。
 
概观
IPv6 Prefix Guard可以在IPv6 Source Guard功能中工作,该功能通过基于DHCPv6 Snooping绑定表和手动配置的静态IPv6绑定过滤流量来限制非路由的第2层接口上的IPv6流量。使用DHCPv6前缀委派将IPv6前缀委派给设备时,使用IPv6前缀保护。IPv6 Prefix Guard将记录分配给链路的前缀地址范围,并使用此范围之外的前缀阻止其源地址来源的流量。
 
配置(支持CLI / WEB GUI / SNMP)
CLI命令
ipv6 source-guard { sip | sdp | max-binding }
 
[CLI格式]
 
    sip - 启用IPv6源地址过滤。
    sdp - 启用IPv6源前缀过滤。
    max-binding - 限制最大绑定条目。
Console#con
Console(config)#interface ethernet 1/1
Console(config-if)#ipv6 source-guard sdp
Console(config-if)#ipv6 source-guard max-binding 3
Console(config-if)#end
Console#show ipv6 source-guard
Interface   Filter-type   Max-binding
---------   -----------   -----------
Eth 1/1     SDP                     3
Eth 1/2     DISABLED                5
Eth 1/3     DISABLED                5
  • 在全局配置模式下添加静态IPv6源保护或IPv6前缀保护绑定条目。

[CLI格式]
ipv6 source-guard binding Mac-Address vlan VLAN_ID { IPv6-Address | IPv6-Prefix } interface ethernet Unit/Port
 
    Mac-Address - 有效的单播MAC地址。(xxxxxx或xxxxxxxxxxxx)
    VLAN_ID - 已配置VLAN的ID。(范围:1-4094)
    IPv6-Address - 对应的完整IPv6地址。
    IPv6-Prefix - IPv6-address / prefix-length形式的对应IPv6前缀。
    单位 - 单位标识符。(范围:1)
    端口 - 端口号。(范围:1-28或52)

Console#con
Console(config)#ipv6 source-guard binding 90-E6-BA-63-96-CD vlan 1 2001:b000:2::/64 interface ethernet 1/21
Console(config)#end
Console#show ipv6 source-guard binding
DHCPV6SNP:
 DHCP - Stateful address
NDSNP:
 ND - Stateless address
STA - Static IPv6 source guard binding

MAC Address    IPv6 Address/IPv6 Prefix                VLAN Interface Type
-------------- --------------------------------------- ---- --------- ----
90E6-BA63-96CD                        2001:b000:2::/64    1  Eth 1/21  STA
 
WEB GUI
  • 在端口接口配置上使能IPv6源保护或IPv6前缀保护,并设置最大绑定号。
[WEB GUI]
安全性> IPv6源保护>端口配置>过滤器类型和最大绑定条目>应用
mceclip0.png
mceclip1.png
 
  • 在交换机上添加静态ipv6源保护或ipv6前缀保护绑定表项。
[WEB GUI]
安全性> IPv6源保护>静态绑定>操作:添加>应用
mceclip2.png
[WEB GUI]
安全性> IPv6源保护>静态绑定>操作:显示
mceclip3.png
 
SNMP
  • 在端口接口配置上使能IPv6源保护或IPv6前缀保护,并设置最大绑定号。
[SNMPSET命令格式]
 
snmpset -v 2c -c private {switch ip} {ip6SrcGuardMode | ip6SrcGuardMaxBinding}。{ip6SrcGuardPortIfIndex} {integer} {value}
 
对于  ip6SrcGuardMode,OID 1.3.6.1.4.1.259.10.1.45.1.74.1.1.2
 设置为禁用(1)表示禁用IPv6 Source Guard。
 设置为srcIp(2)表示启用了IPv6 Source Guard,并通过检查source ip来过滤数据包。
 设置为srcPrefix(3)表示启用了IPv6 Prefix Guard,并通过检查源前缀来过滤数据包。
 
对于  ip6SrcGuardMaxBinding,OID 1.3.6.1.4.1.259.10.1.45.1.74.1.1.3
 该节点标识与端口关联的最大绑定数(取值范围为1~5)
 
对于  ip6SrcGuardPortIfIndex
 此对象标识具有IPv6 Source Guard功能的端口。
 
默认情况下,IPv6源防护在端口接口上禁用。


C:\>snmpwalk -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.74.1.1.2.24
SNMPv2-SMI::enterprises.259.10.1.45.1.74.1.1.2.24 = INTEGER: 1
 
在port24上启用IPv6前缀保护。


C:\>snmpset -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.74.1.1.2.24 i 3
SNMPv2-SMI::enterprises.259.10.1.45.1.74.1.1.2.24 = INTEGER: 3

 
 
显示IPv6源防护的当前模式。
 
C:\>snmpwalk -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.74.1.1.2.24
SNMPv2-SMI::enterprises.259.10.1.45.1.74.1.1.2.24 = INTEGER: 3
在port24上配置IPv6源防护最大绑定表项号为3。
 

C:\>snmpset -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.74.1.1.3.24 i 3
SNMPv2-SMI::enterprises.259.10.1.45.1.74.1.1.3.24 = INTEGER: 3



[结果]
Console#show ipv6 source-guard
Interface   Filter-type   Max-binding
---------   -----------   -----------
Eth 1/23    DISABLED                5
Eth 1/24    SDP                     3
Eth 1/25    DISABLED                5
  • 在交换机上添加静态IPv6源保护或IPv6前缀保护绑定表项。


 
[SNMPSET命令格式]
snmpset -v 2c -c private {switch ip} {ip6SrcGuardBindingVlanIndex | ip6SrcGuardBindingPortIfIndex | ip6SrcGuardBindingStatus}。{ip6SrcGuardBindingType}。{ip6SrcGuardBindingMacAddress}。{ip6SrcGuardBindingIpv6Address}。{ip6SrcGuardBindingPrefixLen}。{ip6SrcGuardBindingMode} {integer} {value}
 
对于  ip6SrcGuardBindingVlanIndex,OID 1.3.6.1.4.1.259.10.1.45.1.74.2.1.4
 该节点标识关联客户端的VLAN ID(取值范围为1~4094)
 
对于  ip6SrcGuardBindingPortIfIndex,OID 1.3.6.1.4.1.259.10.1.45.1.74.2.1.5
 该节点标识关联客户端的端口。
 
对于  ip6SrcGuardBindingStatus,OID 1.3.6.1.4.1.259.10.1.45.1.74.2.1.6
 active(1),表示概念行可供受管设备使用。
 notInService(2),表示概念行存在于代理中,但不可供受管设备使用。
 notReady(3),createAndGo(4),createAndWait(5),destroy(6)
 
对于  ip6SrcGuardBindingType, 
 该节点标识关联客户端的绑定类型。
 静态的(1),dhcp6snp(2),ndsnp(3)
 
对于  ip6SrcGuardBindingMacAddress
 该节点标识关联客户端的MAC地址。(十六进制到十进制)
 
对于  ip6SrcGuardBindingIpv6Address
 该节点标识关联客户端的IPv6地址。(十六进制到十进制)
 
对于  ip6SrcGuardBindingPrefixLen
 该对象指示关联客户端的委托前缀长度。
 
对于  ip6SrcGuardBindingMode
 该对象表示该绑定的模式。
 address(1)表示绑定表项的模式是地址模式。
 prefix(2)表示绑定表项的模式为prefix模式。
 
通过CLI和SNMP读取IPv6源保护动态绑定。
 
 
Console#show ipv6 source-guard binding
DHCPV6SNP:
 DHCP - Stateful address
NDSNP:
 ND - Stateless address
STA - Static IPv6 source guard binding

MAC Address    IPv6 Address/IPv6 Prefix                VLAN Interface Type
-------------- --------------------------------------- ---- --------- ----
382C-4A77-DD37                      2001:db8:2222::/64    1  Eth 1/24 DHCP
mceclip4.png
C:\>snmpwalk -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.74.2.1
SNMPv2-SMI::enterprises.259.10.1.45.1.74.2.1.4.2.56.44.74.119.221.55.32.1.13.184.34.34.0.0.0.0.0.0.0.0.0.0.64.2 = Gauge32: 1  -> VLAN=1
SNMPv2-SMI::enterprises.259.10.1.45.1.74.2.1.5.2.56.44.74.119.221.55.32.1.13.184.34.34.0.0.0.0.0.0.0.0.0.0.64.2 = INTEGER: 24  -> Port=Eth1/24
SNMPv2-SMI::enterprises.259.10.1.45.1.74.2.1.6.2.56.44.74.119.221.55.32.1.13.184.34.34.0.0.0.0.0.0.0.0.0.0.64.2 = INTEGER: 1  -> Status=Active(1)
 
通过SNMP配置静态IPv6前缀绑定。
MAC 90-E6-BA-63-96-CD=144.230.186.99.150.205
IPv6 prefix 2001:b000:2::/64=32.1.176.0.0.2.0.0.0.0.0.0.0.0.0.0
(1)创建静态IPv6前缀绑定表项。
C:\>snmpset -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.74.2.1.6.1.144.230.186.99.150.205.32.1.176.0.0.2.0.0.0.0.0.0.0.0.0.0.64.2 i 5
SNMPv2-SMI::enterprises.259.10.1.45.1.74.2.1.6.1.144.230.186.99.150.205.32.1.176.0.0.2.0.0.0.0.0.0.0.0.0.0.64.2 = INTEGER: 5
 
(2)在VLAN1上设置条目。
C:\>snmpset -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.74.2.1.4.1.144.230.186.99.150.205.32.1.176.0.0.2.0.0.0.0.0.0.0.0.0.0.64.2 u 1
SNMPv2-SMI::enterprises.259.10.1.45.1.74.2.1.4.1.144.230.186.99.150.205.32.1.176.0.0.2.0.0.0.0.0.0.0.0.0.0.64.2 = Gauge32: 1
 
(3)绑定端口21上的条目。
C:\>snmpset -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.74.2.1.5.1.144.230.186.99.150.205.32.1.176.0.0.2.0.0.0.0.0.0.0.0.0.0.64.2 i 21
SNMPv2-SMI::enterprises.259.10.1.45.1.74.2.1.5.1.144.230.186.99.150.205.32.1.176.0.0.2.0.0.0.0.0.0.0.0.0.0.64.2 = INTEGER: 21
 
(4)激活条目。
C:\>snmpset -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.74.2.1.6.1.144.230.186.99.150.205.32.1.176.0.0.2.0.0.0.0.0.0.0.0.0.0.64.2 i 1
SNMPv2-SMI::enterprises.259.10.1.45.1.74.2.1.6.1.144.230.186.99.150.205.32.1.176.0.0.2.0.0.0.0.0.0.0.0.0.0.64.2 = INTEGER: 1
 
通过CLI检查IPv6源防护绑定表项。
mceclip5.png

如果DHCPv6服务器和DHCPv6客户端连接在不同的VLAN /子网中,则用户可以为连接到交换机的主机设备配置DHCPv6中继功能,以便与DHCPv6服务器通信。

DHCPv6中继代理使用中继转发/回复消息来中继服务器和客户端之间的消息。


拓扑结构:

DHCPv6中继配置:

DHCPv6中继包转发程序:

捕获端口2上的数据包。(DHCPv6客户端)

捕获端口1上的数据包。(DHCPv6服务器)

在此示例中,客户端将从DHCP服务器获取2002:db8:0:1 :: 129~2002:db8:0:1 :: 254范围内的IPv6地址。

 

以下是ECS4120系列的示例。

[SNMPSET命令格式]
 
snmpset -v 2c -c private {switch ip} { rlPortInputStatus | rlPortOutputStatus | rlPortInputLimitInKilo | rlPortOutputLimitInKilo}.{ rlPortIndex } {integer} {value}
 
对于  rlPortInputStatus,OID 1.3.6.1.4.1.259.10.1.45.1.16.1.2.1.6
 将OID 1.3.6.1.4.1.259.10.1.45.1.16.1.2.1.6设置为启用(1)输入速率限制。
 将OID 1.3.6.1.4.1.259.10.1.45.1.16.1.2.1.6设置为禁用(2)输入速率限制。
 
对于  rlPortOutputStatus,OID 1.3.6.1.4.1.259.10.1.45.1.16.1.2.1.7
 将OID 1.3.6.1.4.1.259.10.1.45.1.16.1.2.1.7设置为启用(1)输出速率限制。
 将OID 1.3.6.1.4.1.259.10.1.45.1.16.1.2.1.7设置为禁用(2)输出速率限制。
 
对于  rlPortInputLimitInKilo,OID 1.3.6.1.4.1.259.10.1.45.1.16.1.2.1.10
 输入速率限制的值。(范围:<64-10000000>每秒千比特。)
 
对于  rlPortOutputLimitInKilo,OID 1.3.6.1.4.1.259.10.1.45.1.16.1.2.1.11
 输出速率限制的值。(范围:<64-10000000>每秒千比特。)
 
对于  rlPortIndexportTable的端口接口。
 端口或主干的ifIndex值。
 
例:
(1)在端口Eth1 / 1上使能100M的输入速率限制。
(2)在端口Eth1 / 2上使能10M的输出速率限制。
C:\>snmpset -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.16.1.2.1.7.2 i 1
SNMPv2-SMI::enterprises.259.10.1.45.1.16.1.2.1.7.2 = INTEGER: 1
C:\>snmpset -v 2c -c private 192.168.1.1 1.3.6.1.4.1.259.10.1.45.1.16.1.2.1.11.2 i 10000
SNMPv2-SMI::enterprises.259.10.1.45.1.16.1.2.1.11.2 = INTEGER: 10000
结果:
Console#show running-config interface ethernet 1/1
interface ethernet 1/1
 rate-limit input 100000
!
Console#show interfaces switchport ethernet 1/1
Information of Eth 1/1
Broadcast Threshold : Disabled
Multicast Threshold : Disabled
Unknown Unicast Threshold : Disabled
LACP Status : Disabled
Ingress Rate Limit : Enabled, 100000 kbits/second
Egress Rate Limit : Disabled, 1000000 kbits/second
VLAN Membership Mode : Hybrid
Ingress Rule : Disabled
Acceptable Frame Type : All frames
Native VLAN : 1
Priority for Untagged Traffic : 0
GVRP Status : Disabled
Allowed VLAN : 1(u)
Forbidden VLAN :
802.1Q Tunnel Status : Disabled
802.1Q Tunnel Mode : Normal
802.1Q Tunnel TPID : 8100 (Hex)
Layer 2 Protocol Tunnel : None
Broadcast Block : Disabled
Unknown Multicast Block : Disabled
Unknown Unicast Block : Disabled
Console#show running-config interface ethernet 1/2
interface ethernet 1/2
 rate-limit output 10000
!
Console#show interfaces switchport ethernet 1/2
Information of Eth 1/2
Broadcast Threshold : Disabled
Multicast Threshold : Disabled
Unknown Unicast Threshold : Disabled
LACP Status : Disabled
Ingress Rate Limit : Disabled, 1000000 kbits/second
Egress Rate Limit : Enabled, 10000 kbits/second
VLAN Membership Mode : Hybrid
Ingress Rule : Disabled
Acceptable Frame Type : All frames
Native VLAN : 1
Priority for Untagged Traffic : 0
GVRP Status : Disabled
Allowed VLAN : 1(u)
Forbidden VLAN :
802.1Q Tunnel Status : Disabled
802.1Q Tunnel Mode : Normal
802.1Q Tunnel TPID : 8100 (Hex)
Layer 2 Protocol Tunnel : None
Broadcast Block : Disabled
Unknown Multicast Block : Disabled
Unknown Unicast Block : Disabled

概观

双向有源测量协议(TWAMP)是一种开放式协议,用于测量支持TWAMP协议的任何两个设备之间的网络性能。

除了OWAMP的单向度量之外,TWAMP还使用OWAMP的方法和体系结构来定义用于测量双向或往返度量的开放协议。

TWAMP由以下两个协议组成,作为L3层监视器。启动性能测量会话(TWAMP-Control)时,请使用TWAMP控制协议。它通过TCP分层,用于启动和设置测试会话。TWAMP测试协议通过UDP分层,用于发送和接收测试数据包以进行性能测量(TWAMP-Test)。


运营理念

TWAMP由一个网络架构组成,其中Control-Client和Session-Sender的组合是一组主机; 同时,Server和Session-Reflector在另一台主机上配置。我们的交换机支持Server和Session-Reflector(RFC5357)的功能。


建立控制连接


建立测试会议



配置(仅限支持CLI命令)

默认情况下禁用TWAMP反射器。

启用TWAMP反射器功能。

显示当前状态和计时器。


TWAMP Reflector REFWAIT计时器:

当REFWAIT秒没有收到与该会话关联的数据包时,关闭已启动的会话。(默认值:900秒;可配置范围为30 - 3600秒)



[结果]

1)TWAMP客户端使用IPv4地址建立会话并发送测试数据包。

显示当前状态和会话。

通过IPv4地址没有丢包。

2)最大测试次数为5次。

当服务器和客户端位于相同的IPv4网段时,TWAMP可正常工作。

3)当服务器和客户端位于不同的IPv4网段时,TWAMP正常工作。

4)当服务器和客户端处于相同的IPv6网段时,TWAMP正常工作。

5)当服务器和客户端位于不同的IPv6网段时,TWAMP正常工作。

 

支持型号和软件版本:

ECS4120系列v1.2.2.18及以上。

ECS4100系列v1.2.36.191及以上。

交换机上的基本DHCPSNP拓扑和配置如下。

原始行为:(  不支持“vlan-flooding”命令或“vlan-flooding”启用。)

当交换机全局启用DHCPSNP功能时,客户端将通过向不信任端口发送DHCP数据包(发现/请求)来请求IP地址。

该DHCP数据包属于包含在DHCPSNP enable vlan列表中的vlan,交换机将其转发到仅为vlan成员的信任端口。

如果此DHCP数据包属于    包含在DHCPSNP enable vlan列表中的vlan,则交换机会将其转发/泛洪到  所有  其他也是vlan成员的端口。

已禁用DHCPSNP vlan-flooding行为:( 默认情况下,在交换机上启用vlan-flooding。)

当DHCP数据包属于包含在DHCPSNP启用vlan列表中的vlan时,机制相同。

但是,如果此DHCP数据包所属的VLAN    中DHCPSNP包括允许VLAN列表,交换机将    前进/它淹没于这也是VLAN成员,任何其他端口。

用户可以轻松配置DHCP数据包在交换机端口上的转发方式。

[结果]
当DHCP数据包-探索/接收来自客户端的请求。

通过CLI / WEB / SNMP进行配置。

CLI命令

默认为启用vlan-flooding。

Console#con

Console(config)#interface ethernet 1/1

Console(config-if)#ip dhcp snooping vlan-flooding             ---> Enabled

或者

Console(config-if)#no ip dhcp snooping vlan-flooding          ---> Disabled

WEB

安全性> DHCP侦听>步骤:3。配置接口>启用/禁用Vlan Flooding

SNMP

[SNMPSET命令格式]

snmpset -v 2c -c private {switch ip} {dhcpSnoopPortVlanFlooding}。{dhcpSnoopPortIfIndex} {integer} {value}

对于  dhcpSnoopPortVlanFlooding,OID 1.3.6.1.4.1.259.10.1.45.1.46.3.1.1.7

 将OID 1.3.6.1.4.1.259.10.1.45.1.46.3.1.1.7设置为启用(1)vlan洪泛。

 将OID 1.3.6.1.4.1.259.10.1.45.1.46.3.1.1.7设置为禁用(2)vlan洪泛。

对于  dhcpSnoopPortIfIndexdhcpSnoopPortIfIndex的端口接口

 端口或主干的ifIndex值。

启用vlan泛洪。

残疾人vlan洪水。

支持型号和软件版本:

ECS4120系列v1.2.2.23及以上

本文使用ECS4100-28T作为示例。

步骤1:

在端口7上设置静态MAC地址(40-16-7e-66-a4-36)。

snmpset -v 2c -c private 192.168.1.1 .1.3.6.1.2.1.17.7.1.3.1.1.3.1.64.22.126.102.164.53.0 x 02

64.22.126.102.164.53 = 40-16-7e-66-a4-36

这些值表示要设置的MAC地址,MAC地址需要从十六进制转换为十进制。
 

十六进制 -> 十进制
40 -> 64
16 -> 22
7e -> 126


"02" 表示端口7. "x" 表示八位字节。

 - 这是计算值的方法。

请参阅此表单以了解如何指定端口号的值。

 - 如果要设置端口1,则值为80。

注意:

你不能使用单个数字,例如:尾部使用“x 8”,它将失效。 

端口1的正确值应为两位数,例如:“x 80”。

 

这是另一个例子。

 - 如果要设置端口10,则值为0040。

第2步:

设置静态MAC地址类型。

“i”表示整数32。

“3”表示类型3。

 - 此值有五种类型,Edgecore开关支持两种类型

permanent(3)

deleteOnReset(4)

这是结果:

我们可以看到通过SNMP成功配置到MAC表的MAC地址。

 

支持的型号: ECS4120 系列 (V1.2.2.13)

SNMPSET 命令格式.

snmpset -v 2c -c private {switch IP Address} {inetCidrRouteStatus}.{IPv4 or IPv6}.{Destination network segment}.{mask}.{IPv4 or IPv6}.{Next hop} {integer} {value}

{inetCidrRouteStatus}

  • OID: 1.3.6.1.2.1.4.24.7.1.17

{IPv4 or IPv6} 

  • IPv4 OID: 1.4    -->  1 = IPv4 , 4 = IPv4 address is 4 byte.
  • IPv6 OID: 2.16  -->  2 = IPv6 , 16 = IPv6 address is 16 byte. (Please indicate in decimal. e.g. 2002::1 = 32.2.0.0.0.0.0.0.0.0.0.0.0.0.0.1)

{value}

  • 4 = Active 
  • 6 = Destroy

通过SNMP配置Configure IPv4 静态路由。

  • 添加IPv4静态路由如下:
  • NET-SNMP命令:
    snmpset -v 2c -c private 192.168.2.10 1.3.6.1.2.1.4.24.7.1.17.1.4.192.168.87.0.24.1.4.192.168.2.11 i 4
{inetCidrRouteStatus=1.3.6.1.2.1.4.24.7.1.17}.{IPv4=1.4}.{Destination network segment=192.168.87.0}.{mask=24}.{IPv4=1.4}.{Next hop=192.168.2.11}.{integer} {value=4}

通过SNMP配置IPv6静态路由

  • 添加IPv6静态路由如下:
  • NET-SNMP命令: 
    snmpset -v 2c -c private 192.168.2.10 1.3.6.1.2.1.4.24.7.1.17.2.16.32.2.135.135.0.0.0.0.0.0.0.0.0.0.0.0.64.2.16.32.2.0.0.0.0.0.0.0.0.0.0.0.0.0.1 i 4
{inetCidrRouteStatus=1.3.6.1.2.1.4.24.7.1.17}.{IPv6=2.16}.{Destination network segment="2002:8787::"(Please indicate in Decimal)}.{mask=64}.{IPv6=2.16}.{Next hop="2002::1"(Please indicate in Decimal)}.{integer} {value=4}

结果:
!
interface vlan 1
 ip address 192.168.2.10 255.255.255.0
!
interface craft
!
!
ip route 192.168.87.0 255.255.255.0 192.168.2.11
!
!
interface vlan 1
 ipv6 address 2002::1/64
!
ipv6 route 2002:8787::/64 2002::1
!
ECS4100系列上的零接触部署。
 
当交换机使用出厂默认配置引导时,它支持从远程服务器自动获取IP地址和配置文件。一旦交换机安装了新配置,它就可以在服务器上检测到新版本时自动升级当前的操作代码。
 
拓扑:

 
过程:
步骤1:
准备DHCP服务器和TFTP服务器,并将其连接到ECS4100-12T。
 
步骤2:
准备ECS4100-12T的配置和较新的固件。
ECS4100-12T的配置:
启用自动代码升级功能,并配置IP地址或其他所需功能。
Console(config)#upgrade opcode auto
Console(config)#upgrade opcode reload 
Console(config)#upgrade opcode path tftp://192.168.1.2/ 
Console(config)#interface vlan 1 
Console(config-if)#ip address 192.168.1.1/24 
 
第3步:
保存配置(Copy running-config)到远程设备进行更多修改,然后将使用过的配置放到服务器。
Console#copy running-config tftp
TFTP server IP address: 192.168.1.2
Destination file name: test.cfg
Success.
Console#
 
步骤4:
将固件名称修改为“ ECS4100-series.bix ”。
请注意,TFTP服务器上存储的新映像的名称必须为ECS4100-series.bix。


第5步:
在DHCP服务器上配置设置。
必须在DHCP服务器上启用选项66/67。

 
步骤6:
使用出厂默认配置启动ECS4100-12T。
Console 
#configure 
Console(config)#boot system config:Factory_Default_config.cfg Console(config)#exit Console 
#reload 
 
步骤7:
启用DHCP动态配置。
Console(config)#ip dhcp dynamic-provision 

 
步骤8:
ECS4100-12T从DHCP服务器获取IP地址。


捕获包含option66 / 67的DHCP数据包。



在ECS4100-12T安装新配置后,它开始寻找新映像。
然后,当在服务器上检测到新版本时,ECS4100-12T会自动升级当前的操作代码。

ECS2100系列固件版本v1.2.2.12及更高版本具有新的软件增强功能,支持第2层/第3层DHCP中继功能。 用户可以通过以下命令选择使用L2或L3 DHCP 中继(默认为L3)。 

第2层DHCP中继的设置

Console(config)#ip dhcp l2 relay

第3层DHCP中继的设置

Console(config)#ip dhcp l3 relay

当客户端和DHCP服务器在同一个VLAN和子网中时,客户端可以直接从DHCP服务器获取IP地址。 但是,在实际网络中,客户端可能位于不同的子网和VLAN中,然后DHCP中继功能可以帮助从不同子网中的DHCP服务器获取IP地址。

 

- L2 DHCP 中继

L2 DHCP Relay功能可用于添加子选项信息(DHCP Option 82.),DHCP服务器可以引用它来分配相应的IP地址

 

拓扑:

 

ECS2100-28T上的配置:

1) 配置端口2到VLAN 2
 

Console(config)#interface ethernet 1/2
Console(config-if)#switchport native vlan 2
Console(config-if)#switchport mode access

2) 在VLAN 接口设置IP地址
 

Console(config)#int vlan 1
Console(config-if)#ip address 192.168.1.1/24
Console(config-if)#exit

3) 启用L2 DHCP中继并配置DHCP服务器的IP地址

Console(config)#ip dhcp l2 relay
Console(config)#ip dhcp relay information option
Console(config)#ip dhcp relay server 192.168.1.254


L2 DHCP中继数据包转发程序

 

在此示例中,客户端将从DHCP服务器获取192.168.2.240~192.168.250范围内的IP地址。 

==================================================================

 

- L3 DHCP 中继

L3 DHCP中继功能将DHCP广播数据包转换为单播数据包并添加DHCP中继代理IP地址。 然后DHCP服务器可以参考中继代理IP地址来分配相应的IP地址。

 

拓扑:

在ECS2100-28T上的配置:

1) 配置端口2为VLAN 2,端口3为VLAN 3

Console(config)#interface ethernet 1/2
Console(config-if)#switchport native vlan 2
Console(config-if)#switchport mode access
Console(config-if)#exit
Console(config)#interface ethernet 1/3
Console(config-if)#switchport native vlan 3
Console(config-if)#switchport mode access
Console(config-if)#exit

2) 在VLAN接口上配置IP地址

Console(config)#int vlan 1
Console(config-if)#ip address 192.168.1.1/24
Console(config-if)#exit
Console(config)#int vlan 2
Console(config-if)#ip address 192.168.2.1/24
Console(config-if)#exit
Console(config)#int vlan 3
Console(config-if)#ip address 192.168.3.1/24
Console(config-if)#exit

3) 在VLAN接口上启用L3 DHCP中继并配置DHCP中继服务器

Console(config)#ip dhcp l3 relay
Console(config)#int vlan 2

Console(config-if)#ip dhcp relay server 192.168.1.254
Console(config-if)#exit
Console(config)#int vlan 3
Console(config-if)#ip dhcp relay server 192.168.1.254
Console(config-if)#exit

 

L3 DHCP中继数据包转发程序:

客户端B示例:

在这个例子中,
客户端A可以获取DHCP服务器的192.168.2.240-250范围内的IP地址。
客户端B可以获取DHCP服务器的192.168.3.240-250范围内的IP地址。

如何升级ECS4120加载器版本以扩展ECC(纠错码)支持?

ECS4120 加载器版本0.0.3.0及更高版本支持ECC(纠错码)。

环境与准备:
  1. ECS4120开关(其加载器版本为0.0.2.6。通过命令“show version”检查)
  2. 带有一个串行COM端口的Windows PC(Win7,Win8或Win10)
  3. 脚本 - ECS4120_uboot_upgrade_v1.0.2_BH2.zip
 
配置:修改config.ini
  • [serial]部分:串行COM端口
注意: 请勿在config.ini中修改[product]部分的“type”参数

示例:


如何检查PC上的串行COM端口?
在设备管理器中(开始 - >运行 - > devmgmt.msc)




注意:
在运行脚本之前,请关闭PC上的所有终端并关闭交换机电源。
 
升级加载程序:
步骤1:运行脚本“uboot_upgarde.exe”。
双击“uboot_upgrade.exe”以运行该脚本。


步骤2:打开开关
脚本将自动执行。


升级后,uboot_upgrade.exe将自行关闭。

注意:
运行脚本时,请勿拔下控制台电缆并拔下电源线。
 
如果 失败了 要升级,请将您的请求和日志文件发送到  support@edge-core.com
如何在ECS2100系列上通过SNMP检查MAC地址计数?
 
在原始设计中,用户只能通过CLI命令和WEB界面检查整个系统使用的MAC地址数和可用MAC地址数。Edgecore实现通过SNMP读取总/动态/静态MAC地址计数。
支持版本:ECS2100系列V1.2.2.12及以上版本。
 
[SNMPSET命令格式]
snmpwalk -v 2c -c private {switch ip} { amtrMacAddrDynamicCount | amtrMacAddrStaticCount | amtrMacAddrTotalCount }
 
对于amtrMacAddrDynamicCount, OID 1.3.6.1.4.1.259.10.1.43.1.1.8.4
dot1dTpFdb条目在BRIDGE-MIB中的数量
对于amtrMacAddrStaticCount, OID 1.3.6.1.4.1.259.10.1.43.1.1.8.5
dot1dStaticTable 条目在BRIDGE-MIB中的数量
对于amtrMacAddrTotalCount, OID 1.3.6.1.4.1.259.10.1.43.1.1.8.6
dot1dTpFdbTable 和 dot1dStaticTable 条目的总数
 
例如,以下是CLI命令显示的当前mac-address表条目和mac-address计数。


 
以下是SNMP显示的动态/静态/总MAC地址计数的数量。
(1) amtrMacAddrDynamicCount, OID 1.3.6.1.4.1.259.10.1.43.1.1.8.4
动态MAC地址数:5 

(2) amtrMacAddrStaticCount, OID 1.3.6.1.4.1.259.10.1.43.1.1.8.5
静态MAC地址数:2 

(3) amtrMacAddrTotalCount, OID 1.3.6.1.4.1.259.10.1.43.1.1.8.6
MAC地址总数:7
如何锁定端口上指定的MAC地址?(端口安全+网络访问MAC过滤器)


示例:(在ES3510MA上测试)
 
例外:允许端口1仅学习mac-filter中指定的MAC地址。
 
拓扑:

 
以下是配置:
 
设置“network-access mac-filter”
Console(config)#network-access mac-filter 2 mac-address 00-E0-4C-68-01-5A
Console(config)#network-access mac-filter 2 mac-address B8-AE-ED-BB-08-6F
 
Console(config)#interface ethernet 1/1
Console(config-if)#port security "enable port security"
Console(config-if)#port security max-mac-count 3 "allow port 1 could learn three MAC-Address"
Console(config-if)#network-access port-mac-filter 2 "MAC-Address-Table only learn MAC-Address which I setting."
 
结果:
检查MAC地址表。


检查端口安全性。

从交换机ping到PC1,PC2,PC3。






从PC3捕获数据包。
PC3可以从交换机接收ARP请求数据包,并回复ARP应答交换机。
由于我在交换机上设置了mac-filter,这就是为什么交换机没有学习PC3的MAC,ping失败的原因。
如何计算ECS4100系列上IGMPSNP / MVR条目的到期时间?
 
当一个组的计时器到期时,它将从IGMPSNP组表/ MVR成员表中删除,因此,该组的多播流量将停止转发。一旦交换机收到组的IGMP报告包,计时器就会开始计算或更新。
 
IGMP监听:

IGMPSNP过期时间= 
最后成员查询计数x查询间隔+查询响应间隔
 
例如:
默认值:125 x 2 + 10 = 260秒= 4分20秒
 

MVR:

MVR过期时间= 
MVR稳健性值x MVR代理查询间隔+ 10秒(静态)
 
例如:
默认值:125 x 2 + 10 = 260秒= 4分20秒

注意:启用/禁用“MVR代理切换”不会影响到期时间。

 

如何配置802.1x PAE请求者?

支持型号:
ES3510MA,ES3528MV2,ECS3510-28T / 52T,ECS4110系列,ECS4510系列,ECS4620系列

场景:

 
当设备连接到端口时,端口必须向网络上的另一个验证器提交请求; 但是,最终客户端不支持802.1x身份验证或阻止不信任设备,也不支持非支持请求者设备与网络的连接。用户可以配置身份配置文件参数以将此交换机标识为请求者,并为必须通过远程身份验证器对客户端进行身份验证的端口启用dot1x请求者模式。

测试程序:
步骤1)配置管理IP地址
ECS4120-28Fv2:
   ECS412028Fv2 #configure 
   ECS412028Fv2(config)#interface vlan 1 
   ECS412028Fv2(config-if)#ip address 192.168.1.50/24 
 
步骤2)定义外部RADIUS服务器
ECS4120- 28Fv2:
   ECS412028Fv2 #configure 
   ECS412028Fv2(config)#radius-server 1 host 192.168.1.4 key support 
 
步骤3)检查RADIUS 
ECS412028Fv2 的配置#show radius-server
远程RADIUS服务器配置:
服务器1:
服务器IP地址:192.168.1.4
认证端口号:1812 
会计端口号:1813 
转发时间:2 
请求超时:5
 
步骤4)在ECS4120-28Fv2上全局启用802.1x端口认证
ECS4120-28Fv2:
   ECS412028Fv2 #configure 
   ECS412028Fv2(config)#dot1x system-auth-control 
 
步骤5)在交换机端口
ECS4120-28Fv2 上配置802.1x模式:
   ECS412028Fv2 
   #configure ECS412028Fv2( config)#interface ethernet 1/23 
   ECS412028Fv2(config-if)#dot1x port-control auto 
 
步骤6)允许多个主机连接到同一个交换机端口
ECS4120-28Fv2:
   ECS412028Fv2 
   #configure ECS412028Fv2(config)#interface ethernet 1/23 
   ECS412028Fv2 (config-if)#dot1x operation-mode multi-host 
 
步骤7)检查802.1x配置状态是否正确
ECS4120-28Fv2:
   ECS412028Fv2#show dot1x
   全局802.1X参数:
   系统验证控制:启用
   验证器参数:
   EAPOL通过:禁用
   802.1X端口摘要

端口          类型           操作模式      控制模式         已授权
-------- ------------- -------------- ------------------ ---------
Eth 1/21 Disabled      Single-Host    Force-Authorized   Yes
Eth 1/22 Disabled      Single-Host    Force-Authorized   N/A
Eth 1/23 Authenticator Multi-Host     Auto                     N/A
Eth 1/24 Disabled      Single-Host    Force-Authorized   N/A
Eth 1/25 Disabled      Single-Host    Force-Authorized   N/A
Eth 1/26 Disabled      Single-Host    Force-Authorized   N/A
 
步骤8)尝试从客户端1
客户端 1 ping radius服务器:Ping失败,因为RADIUS服务器未对端口进行身份验证。


步骤9)检查支持dot1x请求方式
ECS4110-28P(DUT)的
ECS4110-28P版本:Dut1#show version 
Unit 1 
序列号:EC1427000158 
硬件版本:R0A 
EPLD版本:0.00 
端口数:28 
主电源状态:Up 
作用:Master 
Loader版本:1.2.0.1 
Linux内核版本:2.6.22.18 
Boot ROM版本:0.0.0.1 
操作代码版本:1.2.3.13
 
步骤10)在端口接口
ECS4110-28P(DUT)上启用dot1x请求方模式:
   Dut1 #configure 
   Dut1(config)#interface ethernet 1/23 
   Dut1(config-if)#dot1x pae supplicant 
 
步骤11)设置dot1x请求方用户名和密码
ECS4110-28P(DUT):
   Dut1#configure
   Dut1(config)#dot1x identity profile username test
   Dut1(config)#dot1x identity profile password support
 
步骤12)重新连接ECS4110-28P的端口1/23以重新进行身份验证。
ECS4110-28P(DUT):
   Dut1 #configure 
   Dut1(config)#interface ethernet 1/23 
   Dut1(config-if)#shutdown 
   Dut1(config-if)#no shutdown 
 
步骤13)检查ECS4120-28Fv2上dot1x的状态
ECS4120-28Fv2:
ECS412028Fv2#show dot1x interface ethernet 1/23
802.1X端口1/23启用验证器
重新验证:禁用
Reauth周期:3600秒
安静时间:60秒
TX周期:30秒
请求者超时:30秒
服务器超时:10秒
Reauth Max重试次数:2 
最大请求数:2 
操作模式:多主机
端口控制:自动
最大MAC计数:5 
入侵操作:阻止流量
 
请求者:70-72-CF-C8-58-8F // ECS4110-28P(DUT )的MAC地址
 
验证器PAE状态机
状态:验证的
Reauth计数:0 
当前标识符:1
 
ECS4110-28P(DUT):
Dut1#show dot1x
全局802.1X参数:
系统验证控制:禁用
验证器参数:
EAPOL通过:禁用
请求者参数:
身份配置文件用户名:test 
802.1X端口摘要

端口       类型          操作模式   控制模式         已授权
-------- ------------- -------------- ------------------ ----------
Eth 1/22 Disabled      Single-Host    Force-Authorized   N/A
Eth 1/23 Supplicant    Single-Host    Force-Authorized   Yes
Eth 1/24 Disabled      Single-Host    Force-Authorized   N/A
Eth 1/25 Disabled      Single-Host    Force-Authorized   N/A
802.1X Port Details
802.1X Authenticator is disabled on port 1/23
802.1X Supplicant is enabled on port 1/23
Authenticated : Yes
Auth-period : 30 seconds
Held-period : 60 seconds
Start-period : 30 seconds
Max-start : 3
 
步骤14)检索Wirehark对RADIUS服务器
身份验证的数据包成功执行


步骤15)尝试再次从客户端1
客户端 1 ping radius服务器:Ping 成功


客户端 2:通过DHCP服务器成功获取IP地址并ping到radius服务器


中继是一种将端口分组并将这些端口之间的链路组合成单个链路的功能。
如下图所示,SW1和SW4之间有两个链接,因此有两个循环:
1.循环A:SW1,SW2,SW3和SW4 
2.循环B:SW1和SW4
 
如果存在多个循环,则会导致诸如浪费CPU利用率之类的问题。为了防止环路,SW1的端口26和27以及SW4的端口26和28应该作为一组中继。通过这种方式,交换机1和4之间的两个链路将被系统逻辑地标识为一个链路,并且仅存在一个环路,其中SW3的端口27被阻塞。
 

使用以下命令在SW1的端口26和27上启用LACP。
 
SW_1#config 
SW_1(config)#interface e 1/26
SW_1(config-if)#lacp 
SW_1(config-if)#int e 1/27 
SW_1(config-if)#lacp
 
使用命令“show interface status port-channel 1”检查中继组成员。如下图所示,SW1的端口26和27是中继群1的成员端口
 
.SW_1#sh int status port-channel 1
中继 1的基本信息:
  端口类型:1000BASE-T 
  MAC地址:70-72-CF-58 -F9-25 
 配置:
  名称:
  端口管理员:启用 
  速度双工:自动
  功能:10half,10full,100half,100full,1000full 
  广播风暴:启用
  广播风暴限制:64 Kbits /秒
  组播风暴:已禁用
  组播风暴限制:64 Kbits /秒
  未知单播风暴:已禁用
  未知单播风暴限制:64 Kbits /秒
  流控制:已禁用
  VLAN中继:已禁用
 当前状态:
  创建者:LACP 
  链路状态:上行
  端口操作状态:向上
  操作速度双工:1000满
  上升时间:0w 0d 0h 3m 45s(225秒)
  流控制类型:无
  最大帧大小:1518字节(标记帧为1522字节)
  成员端口:Eth1 / 26,Eth1 / 27
 
使用命令“show spanning-tree port-channel 1”检查每个端口的角色和状态等信息。
 
SW_1 #sh spanning-tree port-channel 1
中继 1信息
------------------------------------- -------------------------- 
 管理状态:已启用
 角色:指定
 状态:转发
 管理路径成本:0操作
 路径成本:2500 
 优先级:128 
 指定成本:0 
 指定端口:128.33 
 指定根:4096.7072CF58F90B 
 指定网桥:4096.7072CF58F90B
 正向转换:24 
 管理边缘端口:自动操作
 边缘端口:已禁用
 管理链接类型:自动操作
 链接类型:点对点
 泛洪行为:已启用
 生成树状态:已启用
 环回检测状态:已启用
 环回检测释放模式:自动
 环回检测陷阱:已禁用
 环回检测操作:阻止
 根保护状态:已禁用
 BPDU保护状态:已禁用
 BPDU保护自动恢复:已禁用
 BPDU Guard自动恢复间隔:300 
 BPDU过滤器状态:已禁用
 

1.防止循环

 

如上图所示,从VLC服务器到PC2有3条流量路径:
路径1(红色):从SW1端口26到SW4端口26; 
路径2(蓝色):从SW1端口27到SW4端口28; 
路径3(绿色):从SW1端口28到SW2端口27,从SW2端口28到SW3端口27,从SW3端口28到SW4端口27,然后到SW4端口1。

因此,拓扑中有两个循环:

 

如上图所示,当交换机从VCL服务器接收广播,多播或未知单播数据包时,数据包将泛洪到端口26(数据包2黄色)和27(数据包2绿色)。当SW4从端口26接收到数据包时,数据包将泛洪到端口1(数据包3黄色)和端口28(数据包3黄色)。当SW4从端口28接收到数据包时,数据包将泛洪到端口1(数据包3绿色)和端口26(数据包3绿色)。这样,数据包将占用连接到交换机的每个端口,导致无法正常处理数据包,有时会浪费CPU利用率。

生成树协议是一种机制,可自动检测网络中的环路并阻止冗余路径,以便只为网络中的两个节点保留一条路径。快速生成树协议(RSTP)是STP的增强,可提供更快的生成树收敛。RSTP使用BPDU的路径开销,网桥ID和端口优先级/端口ID来确定路径的优先级,然后建立生成树。

2.提供冗余路径

有时用户会故意创建一个循环,以便在路径无法链接的情况下构建冗余路径。当默认路径无法链接时,流量会动态切换到冗余路径并维护网络操作。

 

当SW1端口26和SW4端口26之间的链路断开时,处于阻塞状态(备用角色)的SW1端口27自动转发。因此,来自VLC服务器的流量切换到SW1端口27和SW4端口28之间的链路。

使用命令“show log ram”查看更改日志。

SW_1#sh log ram
[3] 08:59:45 2011-12-08
   'STA topology change happened on Eth 1/27.'
   level : 6, module : 5, function : 1, and event no. : 1
[2] 08:59:45 2011-12-08
   'STP port state: MSTID 0, Eth 1/27 becomes forwarding.'
   level : 6, module : 5, function : 1, and event no. : 1
[1] 08:59:45 2011-12-08
   'STP port state: MSTID 0, Eth 1/26 becomes non-forwarding.'
   level : 6, module : 5, function : 1, and event no. : 1
[0] 08:59:45 2011-12-08
   'Unit 1, Port 26 link-down notification.'
   level : 6, module : 5, function : 1, and event no. : 1


SW_4-0#sh log ram
[2] 08:28:56 2011-12-08
   'STA topology change happened on Eth 1/27.'
   level : 6, module : 5, function : 1, and event no. : 1
[1] 08:28:54 2011-12-08
   'STP port state: MSTID 0, Eth 1/26 becomes non-forwarding.'
   level : 6, module : 5, function : 1, and event no. : 1
[0] 08:28:54 2011-12-08
   'Unit 1, Port 26 link-down notification.'
   level : 6, module : 5, function : 1, and event no. : 1

SW_2-0#sh log ram
[1] 09:00:39 2011-12-08
   'User(admin/Telnet) (192.168.1.1), login successful.'
   level : 6, module : 5, function : 1, and event no. : 1
[0] 08:58:43 2011-12-08
   '192.168.1.1 VTY user admin, logout from PRIV. EXEC mode.'
   level : 6, module : 1, function : 0, and event no. : 1

SW_3-0#sh log ram
[2] 08:28:51 2011-12-08
   'User(admin/Telnet) (192.168.1.1), login successful.'
   level : 6, module : 5, function : 1, and event no. : 1
[1] 08:27:48 2011-12-08
   'STA topology change happened on Eth 1/27.'
   level : 6, module : 5, function : 1, and event no. : 1
[0] 08:27:12 2011-12-08
   '192.168.1.1 VTY user admin, logout from PRIV. EXEC mode.'
   level : 6, module : 1, function : 0, and event no. : 1

用户更改端口优先级以指定转发端口和/或阻塞端口。通常,端口优先级ID较小的端口将配置为转发端口,而端口优先级ID较大的端口则为阻塞端口。例如,如果用户希望将SW1端口27配置为转发端口,并且SW4端口26的端口优先级ID为128,则应将SW1端口27的端口优先级ID更改为小于128的数字

SW_4(config)#interface ethernet 1/27
SW_4(config-if)#spanning-tree port-priority ?
  <0-240>  Spanning-tree port priority value in steps of 16

请注意,端口优先级值是步长16,范围为0-240。
 
SW_4(config-if)#spanning-tree port-priority 16
 

 

如果交换机具有最小的优先级ID,则将其配置为root。因此,通过将优先级ID更改为最小ID,用户可以将任何交换机配置为root。例如,使用以下命令将SW1的优先级更改为4096:

SW_1(config)#spanning-tree priority?
  <0-61440>  Spanning-tree priority value in steps of 4096

请注意,优先级ID值只能以4096为步长进行更改,从0到61440。

SW_1(config)# spanning-tree priority 4096

在将SW1的优先级ID改变为4096之后,SW1被配置为根,并且阻塞端口被改变为SW4端口28和SW3端口27。

如何通过ECS2100系列上的SNMP OID检查端口统计信息?
 
Interface.png
收到的八位字节:
1.3.6.1.2.1.31.1.1.1.6 (ifHCInOctets, 64-bit version)
1.3.6.1.2.1.2.2.1.10 (ifInOctets, 32-bit version)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.6.1
IF-MIB::ifHCInOctets.1 = Counter64: 1751607
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.2.2.1.10.1
IF-MIB::ifInOctets.1 = Counter32: 1751607
 
发送的八位字节:
1.3.6.1.2.1.31.1.1.1.10 (ifHCOutOctets, 64-bit version)
1.3.6.1.2.1.2.2.1.16 (ifOutOctets, 32-bit version)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.10.1
IF-MIB::ifHCOutOctets.1 = Counter64: 1045353
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.2.2.1.16.1
IF-MIB::ifOutOctets.1 = Counter32: 1045353
 
收到的错误:
1.3.6.1.2.1.2.2.1.14 (ifInErrors)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.2.2.1.14.1
IF-MIB::ifInErrors.1 = Counter32: 0
 
传输的错误:
1.3.6.1.2.1.2.2.1.20 (ifOutErrors)
ECS2100 系列不支持次计数器。
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.2.2.1.20.1
IF-MIB::ifOutErrors.1 = No Such Instance currently exists at this OID
 
接收单播数据包当前不存在此类实例:
1.3.6.1.2.1.31.1.1.1.7 (ifHCInUcastPkts, 64-bit version)
1.3.6.1.2.1.2.2.1.11 (ifInUcastPkts, 32-bit version)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.7.1
IF-MIB::ifHCInUcastPkts.1 = Counter64: 79
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.2.2.1.11.1
IF-MIB::ifInUcastPkts.1 = Counter32: 79
 
发送的单播数据包:
1.3.6.1.2.1.31.1.1.1.11 (ifHCOutUcastPkts, 64-bit version)
1.3.6.1.2.1.2.2.1.17 (ifOutUcastPkts, 32-bit version)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.11.1
IF-MIB::ifHCOutUcastPkts.1 = Counter64: 1684
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.2.2.1.17.1
IF-MIB::ifOutUcastPkts.1 = Counter32: 1684
 
收到的丢弃数据包:
1.3.6.1.2.1.2.2.1.13 (ifInDiscards)
ECS2100 系列不支持次计数器,总是返回值0。
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.2.2.1.13.1
IF-MIB::ifInDiscards.1 = Counter32: 0
 
传输的丢弃数据包:
1.3.6.1.2.1.2.2.1.19 (ifOutDiscards)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.2.2.1.19.1
IF-MIB::ifOutDiscards.1 = Counter32: 0
 
接收的组播数据包:
1.3.6.1.2.1.31.1.1.1.8 (ifHCInMulticastPkts, 64-bit version)
1.3.6.1.2.1.31.1.1.1.2 (ifInMulticastPkts, 32-bit version)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.8.1
IF-MIB::ifHCInMulticastPkts.1 = Counter64: 20
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.2.1
IF-MIB::ifInMulticastPkts.1 = Counter32: 20
 
发送的多播数据包:
1.3.6.1.2.1.31.1.1.1.12 (ifHCOutMulticastPkts, 64-bit version)
1.3.6.1.2.1.31.1.1.1.4 (ifOutMulticastPkts, 32-bit version)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.12.1
IF-MIB::ifHCOutMulticastPkts.1 = Counter64: 2134
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.4.1
IF-MIB::ifOutMulticastPkts.1 = Counter32: 2134
 
接收的广播包:
1.3.6.1.2.1.31.1.1.1.9 (ifHCInBroadcastPkts, 64-bit version)
1.3.6.1.2.1.31.1.1.1.3 (ifInBroadcastPkts, 32-bit version)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.9.1
IF-MIB::ifHCInBroadcastPkts.1 = Counter64: 18069
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.3.1
IF-MIB::ifInBroadcastPkts.1 = Counter32: 18069
 
传输的广播数据包:
1.3.6.1.2.1.31.1.1.1.13 (ifHCOutBroadcastPkts, 64-bit version)
1.3.6.1.2.1.31.1.1.1.5 (ifOutBroadcastPkts, 32-bit version)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.13.1
IF-MIB::ifHCOutBroadcastPkts.1 = Counter64: 5833
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.31.1.1.1.5.1
IF-MIB::ifOutBroadcastPkts.1 = Counter32: 5833
 
收到未知数​​据包:
1.3.6.1.2.1.2.2.1.15 (ifInUnknownProtos)
ECS2100系列不支持此计数器。
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.2.2.1.15.1
IF-MIB::ifInUnknownProtos.1 = No Such Instance currently exists at this OID
 
QLen Output - the length of the output packet queue (in packets) :
1.3.6.1.2.1.2.2.1.21 (ifOutQLen)
ECS2100系列不支持此计数器。
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.2.2.1.21.1
IF-MIB::ifOutQLen.1 = No Such Instance currently exists at this OID
 
 
Etherlike.png
单一冲突帧
1.3.6.1.2.1.10.7.2.1.4 (dot3StatsSingleCollisionFrames)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.4.1
SNMPv2-SMI::transmission.7.2.1.4.1 = Counter32: 0
 
对个冲突帧:
1.3.6.1.2.1.10.7.2.1.5 (dot3StatsMultipleCollisionFrames)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.5.1
SNMPv2-SMI::transmission.7.2.1.5.1 = Counter32: 0
 
迟到冲突:
1.3.6.1.2.1.10.7.2.1.8 (dot3StatsLateCollisions)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.8.1
SNMPv2-SMI::transmission.7.2.1.8.1 = Counter32: 0
 
过度冲突:
1.3.6.1.2.1.10.7.2.1.9 (dot3StatsExcessiveCollisions)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.9.1
SNMPv2-SMI::transmission.7.2.1.9.1 = Counter32: 0
 
延迟传输:
1.3.6.1.2.1.10.7.2.1.7 (dot3StatsDeferredTransmissions)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.7.1
SNMPv2-SMI::transmission.7.2.1.7.1 = Counter32: 0
 
帧太长:
1.3.6.1.2.1.10.7.2.1.13 (dot3StatsFrameTooLongs)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.13.1
SNMPv2-SMI::transmission.7.2.1.13.1 = Counter32: 0
 
符号错误:
1.3.6.1.2.1.10.7.2.1.18 (dot3StatsSymbolErrors)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.18.1
SNMPv2-SMI::transmission.7.2.1.18.1 = Counter32: 0
 
暂停帧输入:
1.3.6.1.2.1.10.7.10.1.3 (dot3InPauseFrames)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.10.1.3.1
SNMPv2-SMI::transmission.7.10.1.3.1 = Counter32: 0
 
暂停帧输出:
1.3.6.1.2.1.10.7.10.1.4 (dot3OutPauseFrames)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.10.1.4.1
SNMPv2-SMI::transmission.7.10.1.4.1 = Counter32: 0
 
对齐错误:
1.3.6.1.2.1.10.7.2.1.2 (dot3StatsAlignmentErrors)
ECS2100 系列不支持次计数器。
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.2.1
SNMPv2-SMI::transmission.7.2.1.2.1 = No Such Instance currently exists at this OID
 
FCS 错误:
1.3.6.1.2.1.10.7.2.1.3 (dot3StatsFCSErrors)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.3.1
SNMPv2-SMI::transmission.7.2.1.3.1 = Counter32: 0
 
SQE 测试错误:
1.3.6.1.2.1.10.7.2.1.6 (dot3StatsSQETestErrors)
ECS2100 系列不支持次计数器。
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.6.1
SNMPv2-SMI::transmission.7.2.1.6.1 = No Such Instance currently exists at this OID
 
载波侦听错误:
1.3.6.1.2.1.10.7.2.1.11 (dot3StatsCarrierSenseErrors)
ECS2100 系列不支持次计数器。
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.11.1
SNMPv2-SMI::transmission.7.2.1.11.1 = No Such Instance currently exists at this OID
 
内部MAC接收错误:
1.3.6.1.2.1.10.7.2.1.16 (dot3StatsInternalMacReceiveErrors)
ECS2100 系列不支持次计数器。
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.16.1
SNMPv2-SMI::transmission.7.2.1.16.1 = No Such Instance currently exists at this OID
 
内部MAC发送错误:
1.3.6.1.2.1.10.7.2.1.10 (dot3StatsInternalMacTransmitErrors)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.10.7.2.1.10.1
SNMPv2-SMI::transmission.7.2.1.10.1 = Counter32: 0
 
 
RMON.png
丢弃事件:
1.3.6.1.2.1.16.1.1.1.3 (etherStatsDropEvents)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.3.1
SNMPv2-SMI::mib-2.16.1.1.1.3.1 = Counter32: 0
 
Jabbers :
1.3.6.1.2.1.16.1.1.1.12 (etherStatsJabbers)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.12.1
SNMPv2-SMI::mib-2.16.1.1.1.12.1 = Counter32: 0
 
片段:
1.3.6.1.2.1.16.1.1.1.11 (etherStatsFragments)

C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.11.1
SNMPv2-SMI::mib-2.16.1.1.1.11.1 = Counter32: 0
 
冲突:
1.3.6.1.2.1.16.1.1.1.13 (etherStatsCollisions)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.13.1
SNMPv2-SMI::mib-2.16.1.1.1.13.1 = Counter32: 0
 
接收的八位字节:
1.3.6.1.2.1.16.1.1.1.4 (etherStatsOctets)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.4.1
SNMPv2-SMI::mib-2.16.1.1.1.4.1 = Counter32: 2796960
 
收到的数据包:
1.3.6.1.2.1.16.1.1.1.5 (etherStatsPkts)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.5.1
SNMPv2-SMI::mib-2.16.1.1.1.5.1 = Counter32: 23320
 
广播数据包:
1.3.6.1.2.1.16.1.1.1.6 (etherStatsBroadcastPkts)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.6.1
SNMPv2-SMI::mib-2.16.1.1.1.6.1 = Counter32: 23902
 
组播数据包:
1.3.6.1.2.1.16.1.1.1.7 (etherStatsMulticastPkts)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.7.1
SNMPv2-SMI::mib-2.16.1.1.1.7.1 = Counter32: 2154
 
CRC对齐错误:
1.3.6.1.2.1.16.1.1.1.8 (etherStatsCRCAlignErrors)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.8.1
SNMPv2-SMI::mib-2.16.1.1.1.8.1 = Counter32: 0
 
小型数据包:
1.3.6.1.2.1.16.1.1.1.9 (etherStatsUndersizePkts)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.9.1
SNMPv2-SMI::mib-2.16.1.1.1.9.1 = Counter32: 0
 
大型数据包:
1.3.6.1.2.1.16.1.1.1.10 (etherStatsOversizePkts)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.10.1
SNMPv2-SMI::mib-2.16.1.1.1.10.1 = Counter32: 0
 
64 字节数据包:
1.3.6.1.2.1.16.1.1.1.14 (etherStatsPkts64Octets)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.14.1
SNMPv2-SMI::mib-2.16.1.1.1.14.1 = Counter32: 4522
 
65-127 字节数据包:
1.3.6.1.2.1.16.1.1.1.15 (etherStatsPkts65to127Octets)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.15.1
SNMPv2-SMI::mib-2.16.1.1.1.15.1 = Counter32: 21524
 
128-255 字节数据包:
1.3.6.1.2.1.16.1.1.1.16 (etherStatsPkts128to255Octets)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.16.1
SNMPv2-SMI::mib-2.16.1.1.1.16.1 = Counter32: 887
 
256-511 字节数据包:
1.3.6.1.2.1.16.1.1.1.17 (etherStatsPkts256to511Octets)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.17.1
SNMPv2-SMI::mib-2.16.1.1.1.17.1 = Counter32: 827
 
512-1023 字节数据包:
1.3.6.1.2.1.16.1.1.1.18 (etherStatsPkts512to1023Octets)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.18.1
SNMPv2-SMI::mib-2.16.1.1.1.18.1 = Counter32: 53
 
1024-1518 字节数据包:
1.3.6.1.2.1.16.1.1.1.19 (etherStatsPkts1024to1518Octets)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.2.1.16.1.1.1.19.1
SNMPv2-SMI::mib-2.16.1.1.1.19.1 = Counter32: 6
 
 
Utilization.png
输入八位字节,单位为千位/秒:
1.3.6.1.4.1.259.10.1.43.1.2.6.1.2 (portInOctetRate)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.4.1.259.10.1.43.1.2.6.1.2.1
SNMPv2-SMI::enterprises.259.10.1.43.1.2.6.1.2.1 = Counter64: 0
 
每秒输入数据包:
1.3.6.1.4.1.259.10.1.43.1.2.6.1.3 (portInPacketRate)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.4.1.259.10.1.43.1.2.6.1.3.1
SNMPv2-SMI::enterprises.259.10.1.43.1.2.6.1.3.1 = Counter64: 0
 
输入利用率:
1.3.6.1.4.1.259.10.1.43.1.2.6.1.4 (portInUtil)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.4.1.259.10.1.43.1.2.6.1.4.1
SNMPv2-SMI::enterprises.259.10.1.43.1.2.6.1.4.1 = INTEGER: 0
 
输出八位字节,单位为千位/秒:
1.3.6.1.4.1.259.10.1.43.1.2.6.1.5 (portOutOctetRate)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.4.1.259.10.1.43.1.2.6.1.5.1
SNMPv2-SMI::enterprises.259.10.1.43.1.2.6.1.5.1 = Counter64: 0
 
每秒输出数据包:
1.3.6.1.4.1.259.10.1.43.1.2.6.1.6 (portOutPacketRate)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.4.1.259.10.1.43.1.2.6.1.6.1
SNMPv2-SMI::enterprises.259.10.1.43.1.2.6.1.6.1 = Counter64: 0
 
输出利用率:
1.3.6.1.4.1.259.10.1.43.1.2.6.1.7 (portOutUtil)
C:\>snmpwalk -v 2c -c private 10.2.28.216 1.3.6.1.4.1.259.10.1.43.1.2.6.1.7.1
SNMPv2-SMI::enterprises.259.10.1.43.1.2.6.1.7.1 = INTEGER: 0
如何以privilege-8身份登录并使用“启用”访问权限-15?
 
型号名称:ECS4620系列
固件版本:v1.2.2.19 

1.在tacacs Server 
 

2中设置privilege-8,privilege-15帐户并启用密码。然后,设置以下命令:
Console(config)#tacacs-server 1 host [tacacs server ip] key [tacacs server's key]
Console(config)#authentication login tacacs local 
Console(config)#authentication enable tacacs local 
Console(config)#line console 
Console(config-line-console)#authorization exec default 


3.使用权限-8帐户登录到交换机,并使用enable访问权限-15

注意:如果你想使用telnet登录,你也需要在行vty中使用“authorization exec default”。
 
Console#show privilege 
Current privilege level is 15
Console #configure 
Console(config)#line vty 
Console(config-line-vty)#authorization exec default
描述:
当用户将默认登录方法更改为不使用用户名时,用户只需输入密码即可。
 
  1. 拓扑结构:

 
  1. 交换机配置:
 
  1. 将开关重置为默认值。
Console#conf
Console(config)#boot system config:Factory_Default_Config.cfg
Console(config)#
Console#reload
System will be restarted. Continue  ? y

 
  1. 设置行控制台/ vty密码
Console#config
Console(config)#line console
Console(config-line-console)#password 0 support
Console(config-line-console)#login
Console(config-line-console)#exit
Console(config)#line vty
Console(config-line-vty)#password 0 support
Console(config-line-vty)#login
Console(config-line-vty)#


 
  1. 校验
现在用户通过console或vty登录只需要输入密码。
 
 
当用户使用为console / vty设置的密码登录时,用户的权限级别为0.用户需要使用命令“enable”获取权限级别-15。
默认启用密码为“super”。
 
为什么用户无法为BGP邻居设置描述?
型号:AS5710-54X-EC 

Console(config-router)#neighbor x.x.x.x description Edge-Core
设置邻居描述失败
Console(config-router)#

解决方案:
用户必须设置“neighbor remote-as”。之后,用户可以设置BGP邻居描述。

Console#con
Console(config)#router bgp 1
Console(config-router)#neighbor 192.168.1.2 remote-as 2
Console(config-router)#neighbor 192.168.1.2 description Edge-Core
Console(config-router)#
AS5710-54X-EC支持哪些BGP日志消息?
 
答: AS5710-54X-EC 支持3 BGP 日志消息。
  1. BGP_NEIGHBOR_CHANGE_MESSAGE   "BGP: %s"
  2. BGP_ESTABLISHED_NOTIFICATION_MESSAGE   "BGP established, ip: %s, last err: 0x%04x, state: %s"
  3. BGP_BACKWARD_TRANS_NOTIFICATION_MESSAGE   "BGP backward trans, ip: %s, last err: 0x%04x, state: %s"
答:
不是,所有钰登科技交换机的单元ID都从1开始。
对于某些可堆叠交换机(例如,ECS4510,ECS4620),它可能有4个单元用于管理。然后单元ID从1到4. 
 
例如:
如果客户端连接堆栈中第二个单元的port2,则接口将为“eth 2/2”。
如何在ECS4100系列上设置“自动升级”?
 
场景:
 

 
步骤:
 1。将固件上载到TFTP服务器,并将文件名指定为“ECS4100-series.bix”。

2.在交换机上配置IP地址。(管理IP地址为192.168.2.10/24默认)
Console#configure
Console(config)#interface vlan 1
Console(config-if)#ip address 192.168.199.10/24
 
3.启用全局自动升级功能模式。
Console(config)#upgrade opcode auto
Console(config)#upgrade opcode reload
 
4.配置TFTP服务器的目录路径。
Console(config)#upgrade opcode path tftp://192.168.199.2/

 
5.保存配置文件。
Console#copy running-config startup-config

6.重启交换机。

7.重启后,交换机将查找较新的固件版本。如果有更新的固件,交换机将自动升级并重新启动系统。

8.现在,交换机启动了更新的版本。
如何在ECS4100系列上设置“DHCP动态配置”?
 
场景:

 
 
简介:
当交换机从DHCP服务器获取IP地址时,将从TFTP服务器下载配置并自动应用配置。
 
步骤:
1。将配置文件放入TFTP服务器。
2. DHCP服务器必须设置选项66(TFTP服务器名称)和67(引导文件名称)。
例如:  
Serva32.exe是一个免费软件工具,包含DHCP和TFTP服务器。(http://www.vercot.com/~serva/

 
3. DHCP选项是默认禁用。用户必须在全局模式下启用“DHCP动态配置”。
Console 
#configure Console(config)#ip dhcp dynamic-provision
 
4.配置交换机从DHCP服务器获取管理IP地址。
Console(config)#interface vlan 1 
Console(config-if)#ip address dhcp
 
5.交换机发送DHCP发现报文获取IP地址。

 
6.当交换机获取IP地址时,它将开始从TFTP服务器下载配置文件并自动应用配置。

*配置文件将自动设置为启动文件。

 

钰登科技交换机(ES3528M,ECS3510-28T,ECS4100-52T)中的电缆诊断测试结果:电缆诊断支持(A)电缆故障,以及故障的状态和大致距离,或(B)未发现故障时的近似电缆长度。

在Ubuntu上安装和配置MRTG

系统信息:
Ubuntu 16.04.2 LTS (桌面版, amd64)

 
包信息:
  1. snmpd           v5.7.3
  2. mrtg               v2.17.4
  3. apache2        v2.4.18

 

安装和配置步骤:

0. 升级包源列表:
sudo apt-get update

 
1. snmpd
1-1  安装包
sudo apt-get install snmp
sudo apt-get install snmpd
 

 
1-2  创建snmp 社区字
echo 'rocommunity public' > /etc/snmp/snmpd.conf
  
1-3  重启snmpd 服务
service snmpd restart
 
  
     
 1-4  测试 snmpd (能够获取OIDs)
 snmpwalk localhost –v 1 –c public
 
  
参考:
http://www.debianhelp.co.uk/snmp.htm
http://www.net-snmp.org/docs/readmefiles.html

2. mrtg
2-1  安装mrtg
sudo apt-get install mrtg

2-2  配置mrtg.cfg
sudo vi /etc/mrtg.cfg

 
3. apache2
3-1  安装apache2
sudo apt-get install apache2

 
3-2  配置apache2.cfg
sudo vi /etc/apache2/apache2.cfg

在此文件末尾,添加Alias /mrtg “/var/www/mrtg”到连接URL至文件。
语法: Alias URL-path file-path/directory-path
 
 3-3  创建行的文件保存MRTG 数据。
 sudo mkdir /var/www/mrtg
  
 3-4创建MRTG数据(需要执行3次)
  sudo env LANG=C /usr/bin/mrtg /etc/mrtg.cfg

如果成功,您可以在/ var / www / mrtg /下找到数据
 
3-5将test.html链接到index.html
sudo ln –s /var/www/mrtg/test.html /var/www/mrtg/index.html
 
此命令可以使用http://192.168.1.20/mrtg访问MRTG页面。
  无需使用http://192.168.1.20/mrtg/test.html访问此页面。
 
3-6重启apache Web服务
service apache2 restart


结果:
现在可以访问MRTG统计页面(http:// Ubuntu_server的IP / mrtg)
此页面将每5分钟刷新一次。
 
如何在ES3510MA上配置QinQ(基本QinQ)?


固件版本:1.5.1.18 
IEEE 802.1Q隧道(QinQ隧道)对具有多个VLAN的客户使用单个服务提供商VLAN(SPVLAN)。
QinQ隧道通过使用VLAN-in-VLAN层次结构扩展VLAN空间,保留客户的原始标记数据包,并向每个帧添加SPVLAN标记(也称为双标记)。
 
在SW 1和SW4 
1.配置访问模式
Console(config)#interface ethernet 1/1
Console(config-if)#switchport mode access
Console(config-if)#switchport native vlan 2
Console(config-if)#switchport allowed vlan remove 1
2. 配置中继模式
Console(config)#interface ethernet 1/9
Console(config-if)#switchport mode trunk
Console(config-if)#switchport allowed vlan add 2 tagged
Console(config-if)#switchport allowed vlan remove 1
 
在SW2 和SW3上
1. 启用QinQ  
Console(config)#dot1q-tunnel system-tunnel-control
2. 配置Q-in-Q 接入端口
Console(config)interface ethernet 1/1
Console(config-if)#switchport allowed vlan add 20 untagged
Console(config-if)#switchport native vlan 20
Console(config-if)#switchport allowed vlan remove 1
Console(config-if)#switchport dot1q-tunnel mode access
3. 配置Q-in-Q 上行链路端口
Console(config)interface ethernet 1/5
Console(config-if)#switchport allowed vlan add 20 tagged
Console(config-if)#switchport dot1q-tunnel mode uplink
 
检查交换机状态
Console#show dot1q-tunnel
802.1Q Tunnel Status : Enabled
Port     Mode   TPID (Hex) Priority Mapping
-------- ------ ---------- ----------------
Eth 1/ 1 Access       8100 Disabled        
Eth 1/ 2 Normal       8100 Disabled        
Eth 1/ 3 Normal       8100 Disabled        
Eth 1/ 4 Normal       8100 Disabled        
Eth 1/ 5 Uplink       8100 Disabled        
Eth 1/ 6 Normal       8100 Disabled        
Eth 1/ 7 Normal       8100 Disabled
Eth 1/ 8 Normal       8100 Disabled
Eth 1/ 9 Normal       8100 Disabled
Eth 1/ 10 Normal       8100 Disabled
 
在SW1 到SW2上捕获的数据包

 
在SW2 到SW3上捕获的数据包


在SW3 到SW4上捕获的数据包
我们不支持私有MIB中的启用/禁用PoE功能。
但是,用户可以通过标准MIB-POWER-ETHERNET-MIB启用/禁用PoE功能。
SNMPSET命令格式:
snmpset -v 2c -c public <switch ip> <pethPsePortAdminEnable>。<pethPsePortGroupIndex>。<pethPsePortIndex> <integer> <value> 
pethPsePortAdminEnable = true(1),false(2)
 
例如:
禁用PoE功能on ETH1 / 3。
(1) pethPsePortAdminEnable (Integer 2 : false)
C:\>snmpset -v 2c -c private 192.168.1.1 1.3.6.1.2.1.105.1.1.1.3.1.3 i 2
SNMPv2-SMI::mib-2.105.1.1.1.3.1.3 = INTEGER: 2
 
结果
如何设置流量分段?

支持型号:ECS4620系列,ECS4510系列,ECS4120系列,ECS4100系列,ECS4110系列,ECS4210,ECS3500系列,ECS2100系列,
 
当启用流量分段时,则
  1. 从192.168.1.101到192.168.1.102的Ping将失败。(下行端口到下行端口)
  2. 从192.168.1.101到192.168.1.112的Ping将通过。(下行端口到上行端口)
 

 
设置流量分段
Setting traffic-segmentation
Console(config)#traffic-segmentation uplink ethernet 1/12
Console(config)#traffic-segmentation downlink ethernet 1/1-2
Console(config)#traffic-segmentation
Console(config)#end
Console#show traffic-segmentation
 
 Traffic segmentation Status   :        Enabled
 Uplink-to-Uplink Mode      :        Blocking
 
 Session   Uplink Ports           Downlink Ports
---------   ------------------------------  -----------------------------
    1      Ethernet  1/12        Ethernet  1/1
                                Ethernet  1/2
 
测试:
当流量细分状态显示已启用时,
  1. 从192.168.1.101到192.168.1.102的Ping将失败。
  2. 从192.168.1.101到192.168.1.112的Ping将通过。


当流量细分状态显示为禁用时,
  1. 从192.168.1.101到192.168.1.102的Ping将通过。
  2. 从192.168.1.101到192.168.1.112的Ping也将通过。


拓扑结构:
SNMP版本3提供了涵盖消息完整性,身份验证和加密的安全功能。
用户可以使用SNMPv3读取/写入比SNMP版本1和2更安全的交换机。
 
Switch的配置:
1.  在交换机上配置管理IP地址。
Console#configure
Console(config)#interface vlan 1
Console(config-if)#ip address 192.168.1.1/24
 
2.  创建SNMP“视图”规则,该规则控制用户对MIB的访问。
Console(config)#snmp-server view Super 1.3.6.1.4.1.259.10.1.46.* included
-  “*”符号用于选择OID的整个文本。
 
3.  创建SNMP组并指定安全级别。
Console(config)#snmp-server group Super_group v3 priv read Super write Super
-  SNMPv3支持以下安全级别设置:
auth - 该组正在使用authNoPriv安全级别
noauth - 该组正在使用noAuthNoPriv安全级别
priv - 该组正在使用SNMPv3 authPriv安全级别
 
4.  创建SNMP用户帐户并指定其组。
Console(config)#snmp-server user support Super_group v3 auth md5 test1234 priv des56 test1234
 
 
NET-SNMP:
root@E5100-Ts-TestPC:~# snmpwalk -v 3 -u support -l AuthPriv -a MD5 -A test1234 -x DES -X test1234 192.168.1.1 1.3.6.1.4.1.259.10.1.46.1
现在用户可以使用SNMPv3来读/写交换机。

 

我们有两种不同的MVR设计--L2 MVR和L3 MVR。
这两者的关键区别是客户端收到的组播数据。
例如,请在交换机上找到基本的MVR配置。


 
L2 MVR设计
当交换机启用MVR功能并且状态变为“活动”时,MVR接收器端口将自动加入MVR VLAN作为成员。
一旦客户端加入多播组,客户端就可以接收带有MVR VLAN标记(干线模式)或无标记(混合模式)的组播数据。


 
型号:ECS4620系列,ECS4510系列,ECS4120系列,ECS4100系列,ECS4110系列,ECS4210系列,ECS3510-28T / 52T,ES3528Mv2,ES3510MA 
 
L3 MVR设计
当MVR功能处于活动状态时,MVR接收器端口不会自动加入MVR VLAN作为成员。
当客户端加入组播组时,带有MVR VLAN的组播数据会将VLAN标记替换为客户端VLAN并转发到该端口。


 
型号:ECS4660-28F,ECS4610-24F,ECS4610-26T / 50T
前10G端口

Console#switch stacking-port option ?
  <1-2>堆叠端口  选项
(选项1是前10G端口,如ECS4510-28T或ECS4620-28T中的端口25-26)
Console#switch stacking-port option 1 ?
  <1-8>单元号
Console#switch stacking-port option 1 1
设置完成后,请重新加载交换机。
 
您可以使用“show stacking-port option”命令检查设置。

后10G端口

Console#switch stacking-port option ?
  <1-2>堆叠端口  选项
(选项2是后端10G端口,如ECS4510-28T或ECS4620-28T中的端口27-28)
Console#switch stacking-port option 2 ?
  <1-8>单元号
Console#switch stacking-port option 2 1
设置完成后,请重新加载交换机。
 
您可以使用“show switch stacking-port option”命令检查设置。

 

使用class-map对VLAN流量进行分类,使用policy-map来限制流量速率。
 
配置示例如下所示,
 
ECS4510系列
==== 创建VLAN分类的类映射 ==== 
ECS4510(config)# class-map test
ECS4510(config-cmap)# match vlan 1
====== ================================== 
 
==== 流量策略图 ==== 
ECS4510( config)#policy-map VLAN1_limit 
ECS4510(config-pmap)
#class test ECS4510(config-pmap-c)#warning flow 10000 1600000 conform-action transmit 
violate-action drop(限制为10 Mbps,如果超出则丢弃数据包)
================================================== ============== 
 
==== 将此策略映射应用于端口(入口输入,出口输出)==== 
ECS4510(config)# interface ethernet 1/1
ECS4510(config-if)# service-policy input VLAN1_limit
======================================= ======= 
 
==== 检查配置 ==== 
 
ECS4510# show policy-map
Policy Map VLAN1_limit
Description:
 class test
  police flow 10000 1600000 conform-action transmit violate-action drop
 
ECS4510# show policy-map interface 1/1 input
Service-policy VLAN1_limit
============================

 

 

如何配置ERPS主环和子环?
 
拓扑如下:

 
主环(域):交换机A是主环的RPL所有者。

 
子环(域):交换机E是子环的RPL所有者。

 
屏蔽端口

 
配置
  1. 主环
 
交换机 A:
        A(config)#erps
        A(config)#erps domain major
        A(config-erps)#control-vlan 10
        A(config-erps)#ring-port east interface ethernet 1/1
        A(config-erps)#ring-port west interface ethernet 1/2
        A(config-erps)#rpl owner
        A(config-erps)#enable

 
交换机 B: (交换机 C以及交换机 D 的配置与交换机 B的配置一样)
        B(config)#erps
        B(config)#erps domain major
        B(config-erps)#control-vlan 10
        B(config-erps)#ring-port east interface ethernet 1/1
        B(config-erps)#ring-port west interface ethernet 1/2
        B(config-erps)#enable

 
  1. 子环
交换机C&D是主环和子环的成员。
  • 需要通过“major-domain”命令分配主域名。
  • 仅分配一个环网端口。
交换机 C: (交换机 D 和交换机 C的配置一样)
        C(config)#erps
        C (config)#erps domain sub
        C (config-erps)#major-domain major
        C (config-erps)#control-vlan 20
        C (config-erps)#ring-port west interface ethernet 1/3
        C (config-erps)#enable

 

 
交换机 E:
        E(config)#erps
        E(config)#erps domain sub
        E(config-erps)#control-vlan 20
        E(config-erps)#ring-port east interface ethernet 1/1
        E(config-erps)#ring-port west interface ethernet 1/3
        E(config-erps)#rpl owner
        E(config-erps)#enable

 
交换机 F:
        F(config)#erps
        F(config)#erps domain sub
        F(config-erps)#control-vlan 20
        F(config-erps)#ring-port east interface ethernet 1/1
        F(config-erps)#ring-port west interface ethernet 1/3
        F(config-erps)#enable

 

SNMP读取的“lowerLayerDown”和“down”状态有什么区别?
 
型号:ECS4620系列,ECS4510系列,ECS4120系列,ECS4100系列,ECS4110系列,ECS4210系列,ECS3510-28T / 52T,ES3528Mv2,ES3510MA,ECS2100系列
 
当用户尝试通过SNMP获取接口的当前运行状态时,OID应该是if ifOperStatus(1.3.6.1.2.1.2.2.1.8)。
有两种结果,“lowerLayerDown(7)”和“down(2)”。
IF-MIB :: ifOperStatus.25 = INTEGER:lowerLayerDown(7)
IF-MIB :: ifOperStatus.1001 = INTEGER:down(2)
 
“lowerLayerDown”和“down”状态之间有什么区别?
(1)lowerLayerDown:如果“operstatus”无法更改为UP,并且原因是由于PHY链路断开,
例如,没有连接电缆或管理员关闭/手动关闭。(在当前设计中,它将关闭PHY)或通过以下特定功能关闭。



(2)down:如果operstatus无法更改为UP且原因不是由于PHY链路断开,则会显示为down。
例如,vlan adminstatus down。
 
Console#sh ip int
VLAN 1 is Administrative Up - Link Down
  Address is CC-37-AB-94-80-20
  Index: 1001, MTU: 1500
  Address Mode is User specified
  IP Address: 192.168.2.10 Mask: 255.255.255.0
  Proxy ARP is disabled
  DHCP Client Vendor Class ID (text): ECS2100-10T
  DHCP Relay Server:
Console#

 

 

如何设置交换机集群
支持型号:ECS4620系列,ECS4510系列,ECS4120系列,ECS4100系列,ECS4110系列,ECS4210,ECS3500系列,ECS2100系列,ECS2110系列
 
交换机集群:
交换机集群是一种将交换机分组在一起的方法,可通过单个设备进行集中管理。
 
什么是集群指挥官和集群成员?
交换机集群有一个称为“Commander”的主单元,用于管理集群中的所有其他“成员”交换机。
 
在ECS2100-28T和ECS4110-52P上配置的步骤:
ECS2100-28T(config)#cluster  (在交换机上启用集群。)
ECS4110-52P(config)#cluster 
 
在ECS2100-52T上配置的步骤:
ECS2100-52T(config)#int vlan 1 
ECS2100-52T(config-if)#ip address 192.168.1.1/24 
ECS2100-52T(config)#cluster 
ECS2100-52T(config)#cluster ip-pool 10.1.2.1  
(IP) pool用于为集群中的成员交换机分配IP地址。集群IP地址格式为10.xxx)
ECS2100-52T(config)#cluster commander  (将交换机作为集群Commander启用。)
ECS2100-52T(config) #exit 

 
ECS2100-52T#show cluster candidates
Cluster Candidates:
Role            MAC Address       Description
--------------- ----------------- -----------------------------------------
Candidate       00-E0-0C-11-CC-00   ECS2100-28T
Candidate       CC-37-AB-42-6F-B8   ECS4110-52P
ECS2100-52T#configure
ECS2100-52T(config)#cluster member mac-address 00-E0-0C-11-CC-00 id 1  
(configures a Candidate switch as a cluster Member.)
ECS2100-52T(config)#cluster member mac-address CC-37-AB-42-6F-B8 id 2
ECS2100-52T(config)#exit
 
设置完成后,可以使用“show cluster members”命令检查成员。


 
通过telnet测试。


 

 
通过网络测试



 

 
通过控制台测试:

 

如何在ECS4100系列上通过DiffServ对CoS(802.1P)值进行分类和修改?
 
场景:
 

 
 
步骤:
  1. 将VID(VLAN ID)添加到端口接口。在此示例中,流量将标记VLAN 2. 
          Console#configure
          Console(config)#interface ethernet 1/1
          Console(config-if)#switchport allowed vlan add 2 tagged
          Console(config-if)#exi
          Console(config)#interface ethernet 1/47
          Console(config-if)#switchport allowed vlan add 2 tagged
 
  1. 创建一个类映射以对指定的流量进行分类。在此示例中,它将与CoS 0的流量匹配。
          Console(config)#class-map CoS
          Console(config-cmap)#match cos 0

          Console#show class-map
          Class Map match-any CoS
          Description:
          Match CoS 0
  1. 创建策略映射并使用class命令配置与类映射中定义的条件匹配的流量策略。在此示例中,如果流量与类映射匹配,则CoS的值将被修改为“7”。
    Console(config)#policy-map CoS-test
    Console(config-pmap)#class CoS
    Console(config-pmap-c)#set cos 7

    Console#show policy-map
    Policy Map CoS-test
    Description:
     class CoS
      set CoS 7
  1. 将策略映射应用于特定接口的入口或出口侧。在此示例中,策略映射将应用于端口1的入口。
    Console#configure
    Console(config)#interface ethernet 1/1
    Console(config-if)#service-policy ?
      input   Input direction
      output  Output  direction
    Console(config-if)#service-policy input CoS-test

    Console#show running-config interface ethernet 1/1
    interface ethernet 1/1
     switchport allowed vlan add 2 tagged
     service-policy input CoS-test

    !
结果:
当交换机从端口1收到CoS“0”的数据包时,该CoS将被修改为“7”,然后从端口47发出。
 

 

 

钰登交换机上DHCPv6 侦听选项37(远程ID)的格式
型号:ECS4620系列,ECS4510系列,ECS4120系列,ECS4100系列,ECS4110系列,ECS3510-28T / 52T,ES3528MV2,ES3510MA 
 
根据RFC4649,DHCPv6的格式中继代理Remote-ID选项如下所示:
 
 
在交换机上启用DHCPv6 侦听远程ID选项,并捕获数据包,如下所示。

1)对应DHCPv6中继代理远程ID选项的格式。
选项代码 00 25
选项长度 00 1a
企业号码 00 00 01 03
远程ID值 00 01 00 05 01 03 00 0e 00 01 00 01 52 4e 62 c3 00 12 cf fc 54 92
 
2)
远程ID值 00 01 00 05 01 03 00 0e 00 01 00 01 52 4e 62 c3 00 12 cf fc 54 92
远程ID值的详细定义。
远程ID类型 00 01
VLAN ID 00 05
单元 01
港口 03
DUID的长度 00 0e
DUID 00 01 00 01 52 4e 62 c3 00 12 cf fc 54 92
 
3)DUID(DHCP唯一标识符)  有四种不同的定义,如下所示,第一种用于Edgecore交换机。
1.链路层地址加时间(DUID-LLT) - RFC3315 
2.供应商分配的基于企业号的唯一ID(DUID-EN) - RFC3315 
3.链路层地址(DUID-LL) - RFC3315 
4. UUID-基于DUID(DUID-UUID) - RFC6355 
 
※1. 链路层地址加时间(DUID-LLT) - RFC3315
如何允许属于X级的用户在钰登交换机上执行命令?
支持型号:
ECS4620 系列, 版本: 1.2.2.34
ECS4510 系列, 版本: 1.5.2.34
ECS4120 系列, 版本: 1.0.2.33
ECS4100 系列, 版本: 1.2.4.173
ECS4110 系列, 版本: 1.2.3.12
ECS4210 系列, 版本: 1.0.0.56
ECS3500 系列, 版本: 1.5.2.8
ECS2100 系列, 版本: 1.2.2.9
 
介绍:
具有权限0~14的用户不允许在钰登交换机上执行所有命令。
 
如下所示的图片是权限级别2的默认设置。
具有权限级别2的用户不允许进入配置模式(命令“configure”)。
P.S没有配置命令。

 
解:
我们可以通过命令“privilege”为具有0~14权限的用户分配特定命令。
 
例:
ECS4620系列,版本:1.2.2.34
属于权限级别2的用户能够关闭端口并配置IP地址。
 
在配置之前,您必须知道设置所需的命令数。
例如:
执行模式:configure
配置模式:interface ethernet 1/1
配置模式:interface vlan 1
接口-eth模式:shutdown
接口-vlan模式:ip address
 
配置:
第一步:分配“configure” 命令到第二级
            privilege exec level 2 configure
第二步: 分配“interface ethernet & interface vlan” 命令到第二级
            privilege configure level 2 interface  
           privilege configure level 2 interface Ethernet
           privilege 
configure level 2 interface vlan
 
第三步:分配“shutdown” 命令到第二级
           privilege interface-eth level 2 shutdown
 
第四步:分配“ip address” 命令到第二级
           privilege interface-vlan level 2 ip address
拓扑:

步骤:
  1. 设置FreeRadius服务器
  2. 配置客户端
  3. 配置交换机
  4. 校验
 
  1. 设置FreeRadius服务器
  1. 按照以下命令将freeradius服务器安装到Ubuntu((Ubuntu 14.04):
    FreeRadius ~#apt-get install freeradius -y
  2. 配置“users”和“clients.conf”文件
 
      用户(路径:/ etc / freeradius / users)
  • 用户名“ tsCommonName ”。它必须与client.cnf中的commonName相同(参考步骤3)
  • “Tunnel-Private-Group-ID”参数用于动态添加VLAN

 
Clients.conf(路径:/etc/freeradius/clients.conf)

 
  1. https://freeradius.org/下载FreeRadius源代码
FreeRadius ~#wget ftp://ftp.freeradius.org/pub/freeradius/freeradius-server-3.0.15.tar.gz
解压缩源文件后,使用文件“〜/ freeradius-server-3.0.15 / raddb /certs”取代‘的/ etc /的freeradius /certs’ 
 
参考命令:
FreeRadius certs # pwd
/etc/freeradius/certs
FreeRadius certs # rm -rf *
FreeRadius certs # cp -Rf ~/freeradius-server-3.0.15/raddb/certs/* .
  1. 修改ca文件:server.cnf / client.cnf  
    server.cnf: modify output_password (path: /etc/freeradius/certs/server.cnf)
 
client.cnf: modify output_password, emailAddress and commonName
(路径:/etc/freeradius/certs/client.cnf)
  • commonName需要与users文件中的“Username”相同

 
  1. 启动引导脚本(路径:/ etc / freeradius / certs / bootstrap)
  2. FreeRadius certs # ./bootstrap
  3. 将“ca.pem”,“client.key”和“ ts@example.org.pem ”(与“emailAddress”参数相同)复制到客户端。
          路径:
          /etc/freeradius/certs/ca.pem 
          /etc/freeradius/certs/client.key 
          / etc / freeradius / certs / ts@example.org.pem
  1. 修改eap.conf文件(路径:/etc/freeradius/eap.conf)
  1. 将default_eap_type更改为tls
  1. 删除(删除或注释)make_cert_command
  1. 将“private_key_password”值更改为与server.cnf的output_password相同。
  1. 完成所有服务器端配置后,重新启动FreeRadius服务器。
      您可以使用命令:
  1. FreeRadius freeradius #Service freeradius start =>正常启动服务器或
  2. FreeRadius freeradius #Freeradius -X =>使用调试模式启动服务器。
 
  1. 配置客户端
  1. 获取配置服务器上的三个文件,请参阅“安装FreeRadius服务器”步骤5
“ca.pem”,“client.key”和“ ts@example.org.pem ”(与“emailAddress”参数相同)
 
       2。将CA添加到客户端并更新CA 
           命令:
           root @ ts:/ home / ts / Desktop #cp ca.pem /usr/local/share/ca-certificates/ca.pem.crt 
            root @ ts:/ home / ts / Desktop#update-ca-certificates
  1. 配置客户端的网络配置

 
  1. 配置交换机
  1. 交换机IP:
    Console 
    #configure Console(config)#interface vlan 1 
    Console(config-if)#ip address 192.168.2.46/20
  1. Switch Vlan:
  2. Console(config)#vlan database
    Console(config-vlan)#vlan 3
      3. 802.1x configure:  
          全局配置:  
          Console(config)#dot1x system-auth-control 

          接口配置:  
          Console(config)#interface eth 1/3 
          Console(config-if)#dot1x port-control auto
 
  1. 校验
在客户端身份验证之前,端口#3仅允许属于vlan 1(u)的流量


 
认证后,端口#3允许属于vlan 1(u)和3(t)的流量



       
在show vlan中,您可以看到端口#3动态添加到vlan 3

 

如何通过ECS4120-28P上的CLI和SNMP创建PoE时间范围配置文件?

场景:

ECS4120-28P上的配置:
周期时间和日期
ECS4120-28P#con
ECS4120-28P(config)#time-range TEST
ECS4120-28P(config-time-range)#periodic daily 8 0 to daily 21 0
ECS4120-28P(config-time-range)#exit
ECS4120-28P(config)#interface ethernet 1/1
ECS4120-28P(config-if)#power inline time-range TEST
ECS4120-28P(config-if)#end
ECS4120-28P#
 
[CLI命令]
时间范围名称
periodic 
{每日| 星期五| 星期一| 星期六| 星期天| 星期四| 星期二| 星期三| 平日| 周末 }小时

{每日| 星期五| 星期一| 星期六| 星期天| 星期四| 星期二| 星期三| 平日| 周末 }小时
 
[SNMPSET命令格式] 
1. 启用时间范围
snmpset -v 2c -c private {switch ip} {timeRangeStatus}.{timeRangeIndex} {integer} {value}
对于timeRangeStatus,OID 1.3.6.1.4.1.259.10 .1.45.1.61.1.1.3
 OID 1.3.6.1.4.1.259.10.1.45.1.61.1.1.3设置为有效(1)以创建条目。
 OID 1.3.6.1.4.1.259.10.1.45.1.61.1.1.3设置为无效(2)以销毁条目。
对于timeRangeIndex:时间范围的索引
识别从0开始。 
.2. 创建时间范围
snmpset -v 2c -c private {switch ip} {timeRangeName}。{timeRangeIndex} {string} {name} 
对于 timeRangeName,OID 1.3.6.1 .4.1.259.10.1.45.1.61.1.1.2
配置为字符串,用户应给出时间范围的名称。
 
3.配置时间范围规则
snmpset -v 2c -c private {switch ip} {timeRangePeriodic}。{timeRangeIndex}。{PeriodicType}。{startHour}。{startMinute}。{PeriodicType}。{endHour}。{endMinute} 
{integer } {value} 

对于 timeRangePeriodic,OID 1.3.6.1.4.1.259.10.1.45.1.61.2.1.8
设置OID 1.3.6.1.4.1.259.10.1.45.1.61.2.1.8有效(1)创建条目和定期执行。
OID 1.3.6.1.4.1.259.10.1.45.1.61.2.1.8设置为无效(2)以销毁条目。

对于 PeriodicType, {sunday(0),monday(1),tuesday(2),Wednesday Wednesday(3),thursday(4),Friday(5),Saturday(6),daily(7),weekdays(8),weekend (9)} 
对于startHour和startMinute: 整数。
对于endHour和endMinute: 整数

4.为内联电源分配时间范围
snmpset -v 2c -c private {switch ip} {PSE_Port_TimeRange_Name}.{UnitID}.{PortID} {string} {TimeRange_Name}
对于PSE_Port_TimeRange_Name,OID 1.3.6.1.4.1.259.10.1.45 .1.28.6.1.11
配置为字符串,用户应指定特定的时间范围。
对于UnitID和PortID,
指定应用时间范围的端口。
 
通过SNMP配置示例:
(1) timeRangeStatus, OID 1.3.6.1.4.1.259.10.1.45.1.61.1.1.3 ; timeRangeIndex = 0 (Integer 1 : valid)

(2) timeRangeName, OID 1.3.6.1.4.1.259.10.1.45.1.61.1.1.2 ; timeRangeIndex = 0 (String “TEST”: the profile name is TEST)

(3) timeRangePeriodic, OID 1.3.6.1.4.1.259.10.1.45.1.61.2.1.8 ; timeRangeIndex = 0 ; PeriodicType = daily(7) ; 
startHour = 8 ; startMinute = 0 ; PeriodicType = daily(7) ; endHour = 21 ; endMinute = 0 (Integer 1 : valid)
(4) PSE_Port_TimeRange_Name, OID 1.3.6.1.4.1.259.10.1.45.1.28.6.1.11 ; UnitID = 1 ; PortID = 1
(String “TEST”: Apply the profile TEST)

 
结果:
ECS4120-28P中的时间范围表。

当系统在时间范围(8:00到21:00)运行时,AP将打开电源。





 
当系统超出时间范围时,PSE将不提供电源。




为什么ECS4100系列上的MAC ACL仍然会过滤特定的ARP报文,即使该规则允许ARP报文的源MAC?
 
型号:
ECS4100 series
 
固件版本:
ECS4100 系列 V1.2.4.173
 
模拟场景:
  1. 准备两种类型的ARP数据包。
    A. ARP报头的发送方MAC地址与以太网报头的源MAC地址不同。
    B. The sender MAC address of ARP header is the same as source MAC address of Ethernet header.
  2. 配置MAC ACL,允许ARP报文的源MAC地址,拒绝其他报文。
         Console(config)#access-list mac test
         Console(config-mac-acl)#permit host 0C-C4-7A-06-FB-11 any
         Console(config-mac-acl)#deny any any

      3. 将此MAC ACL应用于端口1的入口。

         Console(config)#interface ethernet 1/1
         Console(config-if)#mac access-group test in

4.将这两个ARP数据包注入端口1.因此,交换机转发B-ARP数据包,但通过MAC ACL过滤A-ARP数据包。

根本原因:
这是芯片组行为。 MAC ACL检查ARP报头的发送方MAC地址,而不是ARP报文的以太网报头的源MAC地址。
如何在钰登交换机上使用L2追踪路由(也就是CFM 链路追踪)?

支持型号
ECS4620系列,版本:1.2.2.34
ECS4510系列,版本:1.5.2.34
ECS4120系列,版本:1.0.2.33
ECS4100系列,版本:1.2.4.173
ECS4110系列,版本:1.2.3.12
ECS3500系列,版本:1.5.2.8
 
以下是样本:(使用ECS4620-28F)
拓扑结构

维护端点(MEP):生成并响应CFM PDU
维护中间点(MIP):将CFM PDU转发为中间维护点 
SW1 配置:
SW1#con
SW1(config)#ethernet cfm domain index 1 name Test level 5
(创建维护域[MD],索引为1,名称为字符串“Test”,MD级别为5)
SW1(config-ether-cfm)#ma index 1 name Test_MA vlan 1
(在MD中创建维护关联[MA]服务,索引为2,名称为“Test_MA”,服务VLAN标识符为“1”)

SW1(config-ether-cfm)#mep crosscheck mpid 20 ma Test_MA
(在SW 3上配置MEP交叉检查,使用mpid 20“Test_MA”.MD的交叉检查列表包含在MA中配置的MEPID(维护端点标识符)列表
SW1(config-ether-cfm)#exit
SW1(config)#interface ethernet 1/1
SW1(config-if)#ethernet cfm mep mpid 10 md Test ma Test_MA
(在端口1上创建mep mpid 10)
 
SW2 配置:
SW2#con
SW2(config)#ethernet cfm domain index 1 name Test level 5
SW2(config-ether-cfm)#ma index 1 name Test_MA vlan 1
SW2(config-ether-cfm)#end
 
SW3 配置:
SW3#con
SW3(config)#ethernet cfm domain index 1 name Test level 5
SW3(config-ether-cfm)#ma index 1 name Test_MA vlan 1
SW3(config-ether-cfm)#mep crosscheck mpid 10 ma Test_MA
SW3(config-ether-cfm)#exit
SW3(config)#interface ethernet 1/1
SW3(config-if)#ethernet cfm mep mpid 20 md Test ma Test_MA
 
链路跟踪SW1端口1到SW3端口1。


下面列出的MAC是端口MAC
8C-EA-1B-57-9B-24 (SW2 port 1/1 MAC)
8C-EA-1b-57-9B-25 (SW2 port 1/2 MAC)
70-72-CF-FD-AE-DA (SW3 port 1/1 MAC)
 
如何在钰登交换机上使用L2追踪路由(也就是CFM 链路追踪)?

支持型号
ECS4620系列,版本:1.2.2.34
ECS4510系列,版本:1.5.2.34
ECS4120系列,版本:1.0.2.33
ECS4100系列,版本:1.2.4.173
ECS4110系列,版本:1.2.3.12
ECS3500系列,版本:1.5.2.8
 
以下是样本:(使用ECS4620-28F)
拓扑结构

维护端点(MEP):生成并响应CFM PDU
维护中间点(MIP):将CFM PDU转发为中间维护点 
SW1 配置:
SW1#con
SW1(config)#ethernet cfm domain index 1 name Test level 5
(创建维护域[MD],索引为1,名称为字符串“Test”,MD级别为5)
SW1(config-ether-cfm)#ma index 1 name Test_MA vlan 1
(在MD中创建维护关联[MA]服务,索引为2,名称为“Test_MA”,服务VLAN标识符为“1”)

SW1(config-ether-cfm)#mep crosscheck mpid 20 ma Test_MA
(在SW 3上配置MEP交叉检查,使用mpid 20“Test_MA”.MD的交叉检查列表包含在MA中配置的MEPID(维护端点标识符)列表
SW1(config-ether-cfm)#exit
SW1(config)#interface ethernet 1/1
SW1(config-if)#ethernet cfm mep mpid 10 md Test ma Test_MA
(在端口1上创建mep mpid 10)
 
SW2 配置:
SW2#con
SW2(config)#ethernet cfm domain index 1 name Test level 5
SW2(config-ether-cfm)#ma index 1 name Test_MA vlan 1
SW2(config-ether-cfm)#end
 
SW3 配置:
SW3#con
SW3(config)#ethernet cfm domain index 1 name Test level 5
SW3(config-ether-cfm)#ma index 1 name Test_MA vlan 1
SW3(config-ether-cfm)#mep crosscheck mpid 10 ma Test_MA
SW3(config-ether-cfm)#exit
SW3(config)#interface ethernet 1/1
SW3(config-if)#ethernet cfm mep mpid 20 md Test ma Test_MA
 
链路跟踪SW1端口1到SW3端口1。


下面列出的MAC是端口MAC
8C-EA-1B-57-9B-24 (SW2 port 1/1 MAC)
8C-EA-1b-57-9B-25 (SW2 port 1/2 MAC)
70-72-CF-FD-AE-DA (SW3 port 1/1 MAC)
 
如何在ECS4620上配置VRRP?

 
  1. 拓扑

 
  1. VRRP Master(ECS4620_Master)配置:
  • 基本配置(详细配置请参考附录)
  1. 创建VLAN 11-13
  2. 配置VLAN IP地址
  3. 设置每个端口允许VLAN
          Port #1: PVID = 11, VID = 11(u)
          Port #2: PVID = 12, VID = 12(u)
          Port #3: PVID = 13, VID = 13(u)
  1. 在下行链路端口上禁用生成树(#1,#2)
  2. 将缺省路由设置为VLAN 13
 
  • VRRP配置(VLAN 11和VLAN 12的虚拟IP地址)
          Master#configure
          Master(config)#interface vlan 11
          Master(config-if)#vrrp 1 ip 172.16.11.254
          Master(config-if)#vrrp 1 priority 200
          Master(config-if)#interface vlan 12
          Master(config-if)#vrrp 2 ip 172.16.12.254
          Master(config-if)#vrrp 2 priority 200
 
  1. VRRP备份(ECS4620_Back_up)配置
  • 基本配置(详细配置请参考附录)
  1. 创建VLAN 11-13
  2. 配置VLAN IP地址
  3. 设置每个端口的允许VLAN
          Port #1: PVID = 11, VID = 11(u)
          Port #2: PVID = 12, VID = 12(u)
          Port #3: PVID = 13, VID = 13(u)
  1. 在下行链路端口禁用生成树(#1,#2)
  2. 将缺省路由设置为VLAN 13
  • VRRP配置(VLAN 11和VLAN 12的虚拟IP地址)
          BackUp(config)#interface vlan 11
          BackUp(config-if)#vrrp 1 ip 172.16.11.254
          BackUp(config-if)#interface vlan 12
          BackUp(config-if)#vrrp 2 ip 172.16.12.254
 
  1. 检查VRRP Master和Backup的VRRP状态
  1. 显示VRRP [ID]
使用“”可以查看每个VRRP的详细信息。
  1. 显示VRRP 简介
使用“”可以查看所有VRRP组的简要信息。
  1. 服务器/客户端配置
在服务器端和客户端,将网关配置为虚拟IP(.254),如下所示:
Server Side Client Side

服务器或客户端向网关发送报文时,目的MAC地址格式为00-00-5E-00-01- [VRRP-ID]
客户端发送数据包

 
服务器发送数据包

 
附录
VRRP Master(ECS4620_Master)配置详情:
  • 基本配置
1. Master#configure
    Master#configure
    Master(config)#vlan database
    Master(config-vlan)#vlan 11-13
 
配置VLAN IP 地址

Master#configure
Master(config)#interface vlan 11
Master(config-if)#ip address 172.16.11.1/24
Master(config-if)#interface vlan 12
Master(config-if)#ip address 172.16.12.1/24
Master(config-if)#interface vlan 13
Master(config-if)#ip address 172.16.13.1/24
 
2. 设置每个端口允许 VLAN
    Master#configure
    Master(config)#interface ethernet 1/1
    Master(config-if)#switchport allowed vlan add 11 untagged
    Master(config-if)#switchport native vlan 11
    Master(config-if)#switchport allowed vlan remove 1
    Master(config-if)#interface ethernet 1/2
    Master(config-if)#switchport allowed vlan add 12 untagged
    Master(config-if)#switchport native vlan 12
    Master(config-if)#switchport allowed vlan remove 1
    Master(config-if)#interface ethernet 1/3
    Master(config-if)#switchport allowed vlan add 13 untagged
    Master(config-if)#switchport native vlan 13
    Master(config-if)#switchport allowed vlan remove 1
 
3. 在下行链路端口禁用生成树(#1,#2)
    Master#configure
    Master(config)#interface ethernet 1/1
    Master(config-if)#spanning-tree spanning-disabled
    Master(config-if)#interface ethernet 1/2
    Master(config-if)#spanning-tree spanning-disabled
 
4. 将默认路由设置为vlan 13
    Master#configure
    Master(config)#ip default-gateway 172.16.13.2
 
VRRP备份(ECS4620_Back_up)配置的详细信息
  • 基本配置
  1. 创建VLAN 11-13
BackUp #configure
BackUp (config)#vlan database
BackUp(config-vlan)#vlan 11-13
 
      2. 配置VLAN IP 地址

BackUp#configure
BackUp(config)#interface vlan 11
BackUp(config-if)#ip address 172.16.11.2/24
BackUp(config-if)#interface vlan 12
BackUp(config-if)#ip address 172.16.12.2/24
BackUp(config-if)#interface vlan 13
BackUp(config-if)#ip address 172.16.13.2/24
 
       3. 设置每个端口允许vlan

BackUp#configure
BackUp(config)#interface ethernet 1/1
BackUp(config-if)#switchport allowed vlan add 11 untagged
BackUp(config-if)#switchport native vlan 11
BackUp(config-if)#switchport allowed vlan remove 1
BackUp(config-if)#interface ethernet 1/2
BackUp(config-if)#switchport allowed vlan add 12 untagged
BackUp(config-if)#switchport native vlan 12
BackUp(config-if)#switchport allowed vlan remove 1
BackUp(config-if)#interface ethernet 1/3
BackUp(config-if)#switchport allowed vlan add 13 untagged
BackUp(config-if)#switchport native vlan 13
BackUp(config-if)#switchport allowed vlan remove 1
 

          4.在下行链路端口禁用生成树(#1,#2)

BackUp#configure
BackUp(config)#interface ethernet 1/1
BackUp(config-if)#spanning-tree spanning-disabled
BackUp(config-if)#interface ethernet 1/2
BackUp(config-if)#spanning-tree spanning-disabled
 
  1. 将默认路由设置为vlan 13
BackUp #configure
BackUp (config)#ip default-gateway 172.16.13.1
如何在ECS4620系列上配置PIM-SM(稀疏模式)?

场景:

ECS4620-28T_SW1上的配置:

SW1#con
SW1(config)#interface ethernet 1/23
SW1(config-if)#switchport allowed vlan add 10 untagged
SW1(config-if)#switchport native vlan 10
SW1(config-if)#switchport allowed vlan remove 1
SW1(config-if)#exit
SW1(config)#interface ethernet 1/24
SW1(config-if)#switchport allowed vlan add 20 untagged
SW1(config-if)#switchport native vlan 20
SW1(config-if)#switchport allowed vlan remove 1
SW1(config-if)#exit
SW1(config)#interface vlan 10
SW1(config-if)#ip address 192.168.10.1/24
SW1(config-if)#ip igmp
SW1(config-if)#ip pim sparse-mode
SW1(config-if)#exit
SW1(config)#interface vlan 20
SW1(config-if)#ip address 192.168.20.1/24
SW1(config-if)#ip igmp
SW1(config-if)#ip pim sparse-mode
SW1(config-if)#exit
SW1(config)#ip multicast-routing
SW1(config)#router pim
SW1(config)#ip pim rp-address 192.168.10.1
SW1(config)#router ospf
SW1(config-router)#network 192.168.10.0 255.255.255.0 area 0
SW1(config-router)#network 192.168.20.0 255.255.255.0 area 0
SW1(config-router)#end


Configuration on ECS4620-28T_SW2:
SW2#con
SW2(config)#interface ethernet 1/23
SW2(config-if)#switchport allowed vlan add 30 untagged
SW2(config-if)#switchport native vlan 30
SW2(config-if)#switchport allowed vlan remove 1
SW2(config-if)#exit
SW2(config)#interface ethernet 1/24
SW2(config-if)#switchport allowed vlan add 20 untagged
SW2(config-if)#switchport native vlan 20
SW2(config-if)#switchport allowed vlan remove 1
SW2(config-if)#exit
SW2(config)#interface vlan 20
SW2(config-if)#ip address 192.168.20.2/24
SW2(config-if)#ip igmp
SW2(config-if)#ip pim sparse-mode
SW2(config-if)#exit
SW2(config)#interface vlan 30
SW2(config-if)#ip address 192.168.30.1/24
SW2(config-if)#ip igmp
SW2(config-if)#ip pim sparse-mode
SW2(config-if)#exit
SW2(config)#ip multicast-routing
SW2(config)#router pim
SW2(config)#ip pim rp-address 192.168.10.1
SW2(config)#router ospf
SW2(config-router)#network 192.168.20.0 255.255.255.0 area 0
SW2(config-router)#network 192.168.30.0 255.255.255.0 area 0
SW2(config-router)#end
 
显示PIM配置的接口信息。
 
 

显示指定接口的组播信息。





显示路由表中的信息。



显示PIM邻居的信息。



显示活动RP和关联的组播路由条目。
 

显示IGMP组的信息。


显示IPv4组播路由表。


 
“MVR传输过滤器”命令的行为是什么?

交换机上的基本MVR拓扑和配置如下。


原始行为:(不支持“transmit-filter”命令或“transmit-filter”禁用。)
当交换机启用MVR功能并且状态变为“活动”时,一旦客户端通过发送报告加入/离开多播组MVR接收器端口。
此报告将转发到所有活动源端口,如下所示。


ES3528MV2_SW1和ES3528MV2_SW2的MVR成员如下。



启用发送 - 过滤器行为:(默认情况下,在交换机上禁用发送过滤器。)
机制相同,但此报告不会转发到启用传输过滤器的端口,如下所示。
用户可以轻松配置报告在MVR源端口上的转发方式。


ES3528MV2_SW1和ES3528MV2_SW2的MVR成员如下。



显示每端口配置的发送过滤器。



支持型号和软件版本:
ECS4210系列v1.0.0.61 
ES3528MV2 v1.5.2.14 
ECS3510-28T / 52T v1.5.2.14 
ES3510MA v1.5.2.14

 

如何在ECS4620系列上启用粘性mac?
支持型号名称:ECS4620系列
软件版本:v1.2.2.39
在原始设计中,端口安全功能将在达到配置的最大数量时停止学习MAC地址。 仅接受具有已存储在动态或静态地址表中的源地址的传入流量。
 
如果启用网络访问老化,则当老化时间到期或检测到新端口上的MAC地址时,将删除交换机的安全MAC地址表。
 
因此我们在ECS4620系列上增强Sticky MAC功能。 将接口连接到网络时,可以启用Sticky MAC功能,并确保仅在此端口上学习MAC地址,并保护其他端口即使端口移动或任何攻击也不会学习MAC地址。
 
拓扑结构:
  1. 端口1启用粘性MAC,并在其上连接PC。 PC的MAC地址是在端口1上学习的。

 
  1. 断开连接到集线器的PC链路,然后移动到端口2.然后,由于已经在端口1上学习了MAC地址,PC将无法通过端口2访问网络。


 
步骤
步骤1:
在端口1上启用端口安全性和粘性MAC。
在全局上启用网络访问老化


步骤2:
将PC连接到端口1.并检查端口1上学习的MAC地址


步骤3:
断开连接到集线器的PC链路,然后移至端口2
确认仍在端口1上学习PC的MAC地址,并且无法在端口2上学习。


第4步:
端口2启用端口安全性并将入侵操作设置为关闭。
(建议设置max-mac-count> 1)


断开连接到集线器的PC链路,然后移至端口2。
通过粘性安全MAC地址确认端口已关闭,并进入其他启用端口安全性的端口。
[增强]扩展DHCPSNP 选项82和PPPoE IA的remote-id和circuit-id的字符。
 
支持型号和固件版本:
ECS4100系列(固件版本1.2.30.183及以上)
ECS4120系列(固件版本1.2.2.5及更高版本)
 
摘要:
代理设置 字符串的长度
PPPoEIA Circuit-id 57个字符
PPPoEIA Remote-id 63个字符
DHCPSNP 选项82 Circuit-id 246个字符* 1
DHCPSNP 选项82 Remote-id 246个字符* 2
 
* 1为了将circuit-id设置为最大246个字符的长度,您必须将remote-id配置为1个字符串。如果要保留DHCPSNP 选项82 Remote-id的默认设置和Mac地址信息(10字节= 4 + 6)。您可以配置的Circuit-id的最大长度为241个字符(255-10-4)
* 2要将remote-id设置为最大246个字符的长度,必须将circuit-id配置为1个字符串。如果要保留DHCPSNP 选项82 Circuit-id的默认设置,包括Vlan-id,模块,端口号信息(8字节= 4 + 2 + 1 + 1),则可以配置的最大Remote-id长度为243人物(255-8-4)
 

 

1.PPPoE IA - 电路ID和远程ID

接入节点必须编码并发送电路ID和远程ID作为PPPoE发现
分组中的TAG,格式如下:


根据TR101,我们附加设置PPPoE IA子标签的能力如下。
PPPoEIA Circuit-id字符串长度为57 
PPPoEIA Remote-id字符串为63 
 
在具有Circuit-id的最大长度设置字符串中,数据包的子标签将为
Type:01 
Length:3f(63)
Value:node id(1字节最小值)+“eth”(占用5个字节)+字符串(剩余57个字节)

在具有Remote-id的最大长度设置字符串中,数据包的子标签将为
类型:02 
长度:3f(63)
值:字符串(保留63个字节)
 
 

2.DHCP中继代理信息选项

本文档定义了一个称为中继代理信息选项的新DHCP选项。它是特定代理提供的子选项的“容器”选项。中继代理信息选项的格式为:

长度N给出代理信息字段中的八位字节总数。“代理信息”字段由每个子选项的一系列SubOpt / Length / Value元组组成,按以下方式编码:

 
没有定义“pad”子选项,并且信息字段不应以255子选项终止。DHCP代理信息选项的长度N应包括子选项代码/长度/值元组的所有字节。由于必须至少定义一个子选项,因此最小中继代理信息长度为两(2)。子选项的长度N应该是仅在该子选项的值字段中的八位字节数。子选项长度可以为零。子选项不需要出现在子选项代码顺序中。
  
DHCP中继代理子选项的初始分配如下:
                
DHCP代理子选项说明
子选项代码
--------------- ----------- ---------------------- 
          1 Agent Circuit ID子选项
          2代理远程ID子选项
 
 
根据RFC3046和TR101,我们附加了设置DHCPSNP 选项82的功能如下。
DHCPSNP 选项82 Circuit-id字符串长度为246. 
DHCPSNP 选项82 Remote-id字符串为246. 
 
注意:DHCPSNP 选项82总长度为255字节,Circuit-id和Remote-id共享此空间。
 
在具有Circuit-id的最大长度设置字符串,而Remote-id手动配置1字节字符串。
Circuit-id字符串的空间为255-4-4-1 = 246字节。

类型:01(子选项1 circuit-id)
长度:f8(248)
类型:01(字符串)
长度:f6(246)
值:字符串(保留246个字节)
 
在具有Remote-id的最大长度设置字符串时Circuit-id手动配置1字节字符串。
Remote-id字符串的空间为255-4-4-1 = 246字节

类型:02(子选项2 remote-id)
长度:f8(248)
类型:04(字符串)
长度:f6(246)
值:字符串(保留246个字节)
 
注意:在Edge-Core交换机上启用DHCPSNP 选项82功能时,Circuit-id和Remote-id的默认设置将具有以下格式。
 

 
因此,在默认设置下,Circuit-id的长度为8个字节,Remote-id的长度为10个字节。为了达到246字节字符串的最大设置,用户必须使用1字节字符串手动配置Circuit-id或Remote-id。
 
如何在ECS4510系列上配置SNMPv3通知消息?
 
 

 
产品型号和软件
ECS4510-28T固件版本:v1.5.2.16 
SNMP服务器软件:MG-soft v10.0.0.4044 
 
配置步骤
1.在ECS4510-28T上设置IP地址。
Console(config)#interface vlan 1 
Console(config-if)#ip address 192.168.1.1 255.255.255.0 
 
2.指定SNMP服务器的“engine-id”。
Console(config)#snmp-server engine-id remote 192.168.1.20 8000052301c0a80114 
*请从SNMP服务器中找到engine-id。
自动生成对于主机唯一的“engine-id”。

 
3.创建远程SNMPv3用户。
Console(config)#snmp-server user andy super remote 192.168.1.20 v3 auth md5 andytest 
*还需要在SNMP服务器上创建相同的用户。

 
4.创建SNMP“视图条目”,该视图条目控制用户对特定通知消息的MIB的访问。
Console(config)#snmp-server view super 1.3.6.1.4.1.259.10.1.24。* included。
*此示例OID可以访问ECS4510-28T的整个MIB树。
 
5.创建SNMP组为已分配的用户设置访问策略,并将SNMP用户映射到SNMP视图。
Console(config)#snmp-server group super v3 auth 
 
6.指定将接收通知消息的目标SNMP服务器。
Console(config)#snmp-server host 192.168.1.20通知andy版本3 auth
*如果我们指定SNMP版本3主机,则community-string将被解释为SNMP用户名。
因此,社区字符串“andy”是用户名。
 
7. SNMP通知收集器将收到SNMPv3陷阱。

 

故障排除 如果SNMP服务器仍然无法从交换机接收陷阱消息。 请继续在SNMP服务器上捕获SNMP数据包,然后您就可以开始进行故障排除了。 一般可分为以下两种情况。

1)主机未收到SNMP数据包。>>>检查交换机的配置。

----------------------------------- 交换机的配置示例------------ ----------------------------------------- 
!
snmp-server engine-id remote 192.168.1.20 8000052301c0a80114
snmp-server group super v3 auth
snmp-server user andy super remote 192.168.1.20 v3 auth md5 andytest
snmp-server view super 1.3.6.1.4.1.259.10.1.24.* included
snmp-server host 192.168.1.20 inform andy version 3 auth
!
!
interface vlan 1
 ip address 192.168.1.1/24
!
----------------------------------- 交换机的配置结束------------ ------------------------------------------------ 
 
2)主机已收到SNMP数据包。>>>检查SNMP服务器和交换机的引擎ID和用户配置文件。
 
为什么ECS4210系列无法在端口接口上启用IPv6 RA 卫士

问题:为什么ECS4210系列无法在端口接口上启用IPv6 RA Guard?
 
问题描述:
当用户希望通过以下命令在端口接口上启用IPv6 RA Guard时,但显示失败。
Console#con
Console(config)#interface ethernet 1/1
Console(config-if)#ipv6 nd raguard
Failed to configure IPv6 RA Guard on port 1/1.
Console(config-if)#
 
解决方案:
为了解决 ECS4210系列上的规则编号问题,R&D为动态TCAM分配添加了新功能。
关于IPv6 RA Guard,它是IPv6规则。
根据tcam设计,您必须更改为“默认”模式,然后才能启用IPv6 RA Guard。(默认为ipv4模式)
Console(config)#tcam allocation ?
  default  allocate one slice for MAC, one slice for IPv4, two slices for IPv6
  ipv4     allocate one slice for MAC, three slices for IPv4, no slices for IPv6
  mac      allocate two slices for MAC, one slice for IPv4, no slices for IPv6
Console(config)#tcam allocation default
请记得保存配置并重启交换机,然后再分配新的分配。
使用IPv4 / MAC模式时,它将共享IPv6表到IPv4 / MAC。
在“IPv4”或“MAC”模式下,它始终无法启用IPv6 RA Guard。
 
[原因] 
芯片有ACL的限制数量的症状。
[目标] 
动态将多余规则分配给其他规则。
[行动]。
==默认模式==
MAC规则:128条规则与MAC ACL,MAC服务策略和保留规则共享。
IPv4规则:128条规则与IPv4 ACL,IPv4服务策略和保留规则共享。
IPv6规则:128条规则与IPv6 ACL,IPv6服务策略和保留规则共享。
 
== IPv4模式== 
MAC规则:128条规则与MAC ACL,MAC服务策略和保留规则共享。
IPv4规则:128条规则与IPv4 ACL共享。256条规则与IPv4服务策略共享。
IPv6规则:0规则。
 
== mac mode == 
MAC规则:128条规则与MAC ACL和保留规则共享。128条规则与MAC服务策略共享。
IPv4规则:128条规则与IPv4 ACL,IPv4服务策略和保留规则共享。
IPv6规则:0规则。